classification
Title: socket.SocketIO hides socket timeouts as blocking errors
Type: Stage:
Components: Versions: Python 3.2, Python 3.3, Python 3.4, Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Ronny.Pfannschmidt
Priority: normal Keywords:

Created on 2013-01-26 11:30 by Ronny.Pfannschmidt, last changed 2013-01-26 12:47 by Ronny.Pfannschmidt. This issue is now closed.

Messages (2)
msg180660 - (view) Author: Ronny Pfannschmidt (Ronny.Pfannschmidt) Date: 2013-01-26 11:30
the change to conform with pep 3114 makes socketSocketIO hide Timeouts,
since they are also denoted with EAGAIN (which is one of the blocking errors a nonblocking socket will raise)

that causes read/readinto return None, when one would expect a Timeout
msg180666 - (view) Author: Ronny Pfannschmidt (Ronny.Pfannschmidt) Date: 2013-01-26 12:47
noticed an error in my testing, sorry for the noise
History
Date User Action Args
2013-01-26 12:47:41Ronny.Pfannschmidtsetstatus: open -> closed
resolution: not a bug
messages: + msg180666
2013-01-26 11:30:10Ronny.Pfannschmidtcreate