classification
Title: shlex fails to parse strings correctly
Type: behavior Stage: test needed
Components: Library (Lib) Versions: Python 2.6
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: BreamoreBoy, collinwinter, georg.brandl
Priority: normal Keywords:

Created on 2007-04-12 22:49 by collinwinter, last changed 2010-10-15 16:13 by georg.brandl. This issue is now closed.

Messages (5)
msg31767 - (view) Author: Collin Winter (collinwinter) * (Python committer) Date: 2007-04-12 22:49
shlex fails to parse

"\!echo \"it's fine\""

and

 "\!echo \"it\'s fine\""

correctly. ValueError("No closing quotation") is raised incorrectly.
msg31768 - (view) Author: Collin Winter (collinwinter) * (Python committer) Date: 2007-04-12 22:50
This should probably be fixed at the same time as #1521950.
msg112268 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2010-08-01 06:27
How do you reproduce this?  The strings seem to work fine with shlex.split().
msg116661 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2010-09-17 13:29
@Georg: seems like your r55549 and r55550 fixed this, am I correct?
msg118794 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2010-10-15 16:13
That particular commit can't be the reason, but some other must be.  Closing as wfm.
History
Date User Action Args
2010-10-15 16:13:04georg.brandlsetstatus: open -> closed
resolution: works for me
dependencies: - shlex.split() does not tokenize like the shell
messages: + msg118794
2010-09-17 13:29:44BreamoreBoysetnosy: + BreamoreBoy
messages: + msg116661
2010-08-01 06:27:25georg.brandlsetnosy: + georg.brandl
messages: + msg112268
2009-03-30 17:04:08ajaksu2setdependencies: + shlex.split() does not tokenize like the shell
type: behavior
stage: test needed
versions: + Python 2.6, - Python 2.5
2007-04-12 22:49:03collinwintercreate