classification
Title: HP-UX: SHLIB_EXT is not set
Type: behavior Stage: resolved
Components: Extension Modules Versions: Python 3.3, Python 3.4
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: skrah Nosy List: python-dev, skrah
Priority: normal Keywords: 3.3regression

Created on 2013-01-17 19:24 by skrah, last changed 2013-01-17 22:44 by skrah. This issue is now closed.

Messages (2)
msg180148 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2013-01-17 19:24
Since 5e33b27c71a8 SHLIB_EXT is not set in configure.ac, since
the block in which $SO is defined has been moved below this line:

AC_DEFINE_UNQUOTED(SHLIB_EXT, "$SO", [Define this to be extension of shared libraries (including the dot!).])


This prevents extension module loading on HP-UX.
msg180149 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2013-01-17 19:45
New changeset 937e9df47ccd by Stefan Krah in branch '3.3':
Issue #16987: Fix definition of SHLIB_EXT.
http://hg.python.org/cpython/rev/937e9df47ccd
History
Date User Action Args
2013-01-17 22:44:59skrahsetkeywords: + 3.3regression
assignee: skrah
status: open -> closed
resolution: fixed
stage: resolved
2013-01-17 19:45:08python-devsetnosy: + python-dev
messages: + msg180149
2013-01-17 19:24:46skrahcreate