classification
Title: idle problem with dark color schemes in kde
Type: behavior Stage:
Components: IDLE Versions: Python 3.2, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE: avoid no-contrast popups and dialogs.
View: 7949
Assigned To: Nosy List: roger.serwy, sahin
Priority: normal Keywords:

Created on 2013-01-16 21:53 by sahin, last changed 2013-01-17 06:46 by roger.serwy. This issue is now closed.

Files
File name Uploaded Description Edit
snapshot-idle.png sahin, 2013-01-16 21:53 idle completions in a dark color theme in kde
Messages (2)
msg180111 - (view) Author: Sureyya Sahin (sahin) Date: 2013-01-16 21:53
I am trying to use IDLE in kde linux environment (kubuntu 12.10). I recently switched to a dark color scheme from kde settings and discovered that IDLE is having issues with dark colors.

The Completions boxes are not readable, after I switched to the dark color scheme in kde. The completions are white text on white background colored boxes which is making the text unreadable. If I select the options in the completions dialog box, my selection is highlighted and thus I can read the text.
msg180119 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2013-01-17 06:46
This is a duplicate of issue7949, but for KDE instead of GTK. I will close this report in favor of the prior one.
History
Date User Action Args
2013-01-17 06:46:34roger.serwysetstatus: open -> closed

nosy: + roger.serwy
messages: + msg180119

superseder: IDLE: avoid no-contrast popups and dialogs.
resolution: duplicate
2013-01-16 21:53:03sahincreate