classification
Title: Problems with float and "6" type
Type: resource usage Stage:
Components: Interpreter Core Versions: Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: christian.heimes, pedrocpneto
Priority: normal Keywords:

Created on 2007-12-25 13:15 by pedrocpneto, last changed 2007-12-25 16:41 by christian.heimes. This issue is now closed.

Messages (2)
msg58989 - (view) Author: Pedro Clemente Pereira Neto (pedrocpneto) Date: 2007-12-25 13:15
Problems with float and "6" type

Hi, I am having problems both in the Windows version on the Linux
version of Python as put some number with some 6 type that it always
returns a value me, following examples:

>>> 2.0
2.0
>>> 1.55
1.55
>>> 1.56
1.5600000000000001
>>> 1.6
1.6000000000000001
>>> 1.63
1.6299999999999999
>>> 1.64
1.6399999999999999
>>> 1.71
1.71
>>> 6.0
6.0

Recalling that the error happens only with the digit 6 in float.
Thanks for attention.

Pedro Clemente Pereira Neto 
Brasil
pedrocpneto at gmail.com
msg58992 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2007-12-25 16:41
Your results are correct and expected. You can find more information at:

http://effbot.org/pyfaq/why-are-floating-point-calculations-so-inaccurate.htm
http://en.wikipedia.org/wiki/IEEE_754
History
Date User Action Args
2007-12-25 16:41:12christian.heimessetstatus: open -> closed
resolution: not a bug
messages: + msg58992
nosy: + christian.heimes
2007-12-25 13:15:01pedrocpnetocreate