classification
Title: Wrong float sum w/ 10.14+10.1 and 10.24+10.2
Type: behavior Stage: resolved
Components: None Versions: Python 3.2
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ezio.melotti, fenrirsoul, mark.dickinson
Priority: normal Keywords:

Created on 2013-01-09 22:57 by fenrirsoul, last changed 2013-01-10 08:43 by mark.dickinson. This issue is now closed.

Messages (3)
msg179495 - (view) Author: (fenrirsoul) Date: 2013-01-09 22:57
When 10.14+10.1 is typed, it's result is 20.240000000000002 and when 10.24+10.2 is typed, it's result is 20.439999999999998, i just found these two occurences.
msg179496 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2013-01-09 22:58
See http://docs.python.org/3/tutorial/floatingpoint.html
msg179497 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2013-01-09 23:01
See also http://docs.python.org/3/faq/design.html#why-are-floating-point-calculations-so-inaccurate
History
Date User Action Args
2013-01-10 08:43:19mark.dickinsonsetnosy: + mark.dickinson
2013-01-09 23:01:02ezio.melottisetmessages: + msg179497
2013-01-09 22:58:54ezio.melottisetstatus: open -> closed

nosy: + ezio.melotti
messages: + msg179496

resolution: not a bug
stage: resolved
2013-01-09 22:57:44fenrirsoulcreate