classification
Title: in 3.3.0 windows 64 idle editor
Type: behavior Stage: resolved
Components: IDLE Versions: Python 3.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ezio.melotti, ned.deily, pargo
Priority: normal Keywords:

Created on 2013-01-06 02:49 by pargo, last changed 2013-01-06 02:56 by ned.deily. This issue is now closed.

Messages (3)
msg179164 - (view) Author: Glenn (pargo) Date: 2013-01-06 02:49
when in the Idle editor this line command does not work:
>>> print "Hello World!"

does not work it says it is a syntax error but 

>>> x="Hello World!"
>>> x
produces this
'Hello World!'
msg179165 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2013-01-06 02:50
That's because in Python 3 print is a function, so you need to do print("Hello World!") instead.
See the Python 3 tutorial: http://docs.python.org/3/tutorial/
msg179166 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2013-01-06 02:56
Also see http://docs.python.org/3/whatsnew/3.0.html#print-is-a-function
History
Date User Action Args
2013-01-06 02:56:15ned.deilysetnosy: + ned.deily
messages: + msg179166
2013-01-06 02:50:54ezio.melottisetstatus: open -> closed

nosy: + ezio.melotti
messages: + msg179165

resolution: not a bug
stage: resolved
2013-01-06 02:49:22pargocreate