classification
Title: cannot catch KeyboardInterrupt when using curses getkey()
Type: behavior Stage: test needed
Components: Library (Lib) Versions: Python 2.7
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: ajaksu2, al65536, ronaldoussoren, vstinner
Priority: normal Keywords:

Created on 2007-03-23 20:50 by al65536, last changed 2015-01-06 11:56 by vstinner. This issue is now closed.

Files
File name Uploaded Description Edit
cursesbug.py al65536, 2007-03-23 20:51 test case
Messages (5)
msg31638 - (view) Author: al65536 (al65536) Date: 2007-03-23 20:50
#!/usr/bin/python
import curses

# Will works
scr=curses.initscr()
key=-1
try:
    try:
        key=scr.getkey()
    except:
        pass
except KeyboardInterrupt:
    key="CTRL-C"
curses.endwin()
print key

# Will fail
scr=curses.initscr()
key=-1
try:
    key=scr.getkey()
except KeyboardInterrupt:
    key="CTRL-C"
curses.endwin()
print key
msg31639 - (view) Author: al65536 (al65536) Date: 2007-03-23 20:51
python file attached
File Added: cursesbug.py
msg87792 - (view) Author: Daniel Diniz (ajaksu2) (Python triager) Date: 2009-05-15 02:36
Seems related to #706406 and #3180.
msg193509 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2013-07-22 07:26
I cannot reproduce this with a recent 2.7 build from mercurial, but can reproduce with /usr/bin/python (2.7.2) on OSX 10.8 and python 2.7.3 on Centos 6.4 system.
msg233529 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2015-01-06 11:56
I cannot reproduce it on Python 2.7.9+. I get the following output which is the expected output:
---
-1
CTRL-C
---

Since this bug is 8 years old. I guess that the bug was already fixed, or maybe it can only be reproduced on a specific platform. But the platform or the specific conditions to reproduce the issue were not described. I close this issue.
History
Date User Action Args
2015-01-06 11:56:57vstinnersetstatus: open -> closed

nosy: + vstinner
messages: + msg233529

resolution: out of date
2014-12-31 16:24:03akuchlingsetnosy: - akuchling
2013-07-22 07:26:51ronaldoussorensetnosy: + ronaldoussoren

messages: + msg193509
versions: + Python 2.7, - Python 2.6
2010-11-12 20:57:33akuchlingsetassignee: akuchling ->
2009-05-15 02:36:58ajaksu2setversions: + Python 2.6, - Python 2.5
nosy: + ajaksu2

messages: + msg87792

type: behavior
stage: test needed
2008-01-21 13:50:17akuchlingsetassignee: akuchling
nosy: + akuchling
title: cannot catch KeyboardInterrupt when using curses getkey() -> cannot catch KeyboardInterrupt when using curses getkey()
2007-03-23 20:50:12al65536create