This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

classification
Title: Transform reST to styled text in bdist_wininst-produced installers
Type: enhancement Stage: resolved
Components: Distutils Versions:
process
Status: closed Resolution: rejected
Dependencies: Superseder:
Assigned To: tarek Nosy List: collinwinter, eric.araujo, jvickroy, loewis, tarek
Priority: low Keywords:

Created on 2007-03-16 19:58 by jvickroy, last changed 2022-04-11 14:56 by admin. This issue is now closed.

Messages (7)
msg31554 - (view) Author: j vickroy (jvickroy) Date: 2007-03-16 19:58
From the definition of long_description:
 
 *'long string'*
     Multiple lines of plain text in reStructuredText format (see http://docutils.sf.net/).
 
in:

  http://docs.python.org/dist/meta-data.html

I incorrectly concluded that the the bdist_wininst installer would provide visual markup for long_description specified in restructured text.

According to Thomas Heller, that is not the case.

I wish to suggest adding this clarification to the distutils documentation perhaps in one or both of the following documents:

 http://docs.python.org/dist/postinstallation-script.html
 http://docs.python.org/dist/meta-data.html

Thanks,

-- jv
msg31555 - (view) Author: Collin Winter (collinwinter) * (Python committer) Date: 2007-03-28 23:46
I'm not quite sure what the problem is. What kind of "visual markup" did you expect?
msg31556 - (view) Author: j vickroy (jvickroy) Date: 2007-03-29 14:26
I expected bold font when using "**" markers, list bullets when using "*" and "-" markers, etc. in the long_description text definition.  Unfortunately, all of these markers are simply passed through unprocessed in the long description text that appears in the opening window when running the generated binary installer.

Does this help clarify the issue?
msg31557 - (view) Author: Collin Winter (collinwinter) * (Python committer) Date: 2007-03-30 03:03
Martin, you handle a lot of the Windows-related code, right? Thoughts on this?
msg113403 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-08-09 11:08
Is there documentation somewhere that would explain what file to produce with what markup?
msg114468 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-08-21 00:09
I added an item to the todo list of distutils2 so that the current behavior is documented: http://bitbucket.org/tarek/distutils2/wiki/Todo
msg213466 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2014-03-13 20:45
The marked-up text is still readable, and PyPI / project’s documentation render nice HTML.  If someone knows how to style text in a wininst program and wants to work on a patch, please reopen this ticket.
History
Date User Action Args
2022-04-11 14:56:23adminsetgithub: 44733
2014-03-13 20:45:57eric.araujosetstatus: open -> closed
versions: - 3rd party
messages: + msg213466

components: + Distutils, - Distutils2
resolution: rejected
stage: resolved
2010-09-29 23:51:02eric.araujosetversions: + 3rd party, - Python 3.2
2010-08-21 00:09:10eric.araujosetnosy: loewis, collinwinter, jvickroy, tarek, eric.araujo
messages: + msg114468
components: + Distutils2, - Distutils, Windows
title: docutils clarification request for "rest" -> Transform reST to styled text in bdist_wininst-produced installers
2010-08-09 11:08:55eric.araujosetassignee: loewis -> tarek

messages: + msg113403
nosy: + eric.araujo, tarek
2010-08-09 04:31:18terry.reedysetversions: + Python 3.2, - Python 3.1, Python 2.7
2009-02-16 16:28:17akitadasettype: enhancement
versions: + Python 3.1, Python 2.7, - Python 2.6, Python 2.5
2008-01-06 12:00:18christian.heimessetcomponents: + Distutils, Windows, - Library (Lib)
versions: + Python 2.6, Python 2.5
2007-03-16 19:58:35jvickroycreate