classification
Title: inconsistency in weekday
Type: Stage:
Components: Documentation Versions: Python 3.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, serhiy.storchaka, v+python
Priority: normal Keywords:

Created on 2012-12-29 06:54 by v+python, last changed 2012-12-29 18:54 by v+python. This issue is now closed.

Files
File name Uploaded Description Edit
t38.py v+python, 2012-12-29 18:53 demonstrate the real bug
Messages (3)
msg178477 - (view) Author: Glenn Linderman (v+python) * Date: 2012-12-29 06:54
Docs say:

date.timetuple()

    Return a time.struct_time such as returned by time.localtime(). The hours, minutes and seconds are 0, and the DST flag is -1. d.timetuple() is equivalent to time.struct_time((d.year, d.month, d.day, 0, 0, 0, d.weekday(), yday, -1)), where yday = d.toordinal() - date(d.year, 1, 1).toordinal() + 1 is the day number within the current year starting with 1 for January 1st.

However, timetuple's 7th element has a range of 0-6 where 0 is Sunday, and d.weekday has a range of 0-6 where 0 is Monday. So the claim of equivalence is false.   "d.weekday()" in the above could be replaced by "( d.weekday() + 1 ) % 7"

I guess datetime consistently uses 0==Monday, and weeks starting on Monday, except for the timetuple (which probably has compatibility constraints which force it to return a different value, which I consider to be more correct).
msg178520 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2012-12-29 18:33
I don't see a difference.

$ ./python -c 'import time; print(time.localtime())'
time.struct_time(tm_year=2012, tm_mon=12, tm_mday=29, tm_hour=19, tm_min=36, tm_sec=35, tm_wday=5, tm_yday=364, tm_isdst=0)
$ ./python -c 'import datetime; print(datetime.date.today().timetuple())'
time.struct_time(tm_year=2012, tm_mon=12, tm_mday=29, tm_hour=0, tm_min=0, tm_sec=0, tm_wday=5, tm_yday=364, tm_isdst=-1)

Can you please provide a full code which demonstrate a problem?
msg178522 - (view) Author: Glenn Linderman (v+python) * Date: 2012-12-29 18:53
Thanks for the response, Serhiy.  I misreported, but there is still a bug in this area, it seems.  Attached is some code.

I was printing out (too) many values from datetime to learn how it worked. I got confused on which ones were printed in which order. The attached code reduces the number of values printed to just those that should be consistent, but according to the docs, aren't.  However, now that I figured out which ones were printed by which code, I no longer find a discrepancy between code and documentation, just a confusing interface whereby weekday can be obtained in three different forms.
History
Date User Action Args
2012-12-29 18:54:37v+pythonsetstatus: open -> closed
resolution: not a bug
2012-12-29 18:53:21v+pythonsetfiles: + t38.py

messages: + msg178522
2012-12-29 18:33:33serhiy.storchakasetnosy: + serhiy.storchaka
messages: + msg178520
2012-12-29 06:54:21v+pythoncreate