classification
Title: sporadic test_faulthandler failure
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.2, Python 3.3, Python 3.4
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Sporadic failure in test_dump_tracebacks_later_file (test_faulthandler)
View: 15971
Assigned To: Nosy List: ezio.melotti, pitrou, vstinner
Priority: normal Keywords:

Created on 2012-12-28 00:01 by pitrou, last changed 2012-12-28 00:17 by ezio.melotti. This issue is now closed.

Messages (2)
msg178351 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2012-12-28 00:01
http://buildbot.python.org/all/builders/AMD64%20Mountain%20Lion%20%5BSB%5D%203.x/builds/631

======================================================================
FAIL: test_dump_traceback_later_file (test.test_faulthandler.FaultHandlerTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Volumes/bay2/buildslave/cpython/3.x.snakebite-mountainlion-amd64/build/Lib/test/test_faulthandler.py", line 490, in test_dump_traceback_later_file
    self.check_dump_traceback_later(file=True)
  File "/Volumes/bay2/buildslave/cpython/3.x.snakebite-mountainlion-amd64/build/Lib/test/test_faulthandler.py", line 476, in check_dump_traceback_later
    filename, loops)
  File "/Volumes/bay2/buildslave/cpython/3.x.snakebite-mountainlion-amd64/build/Lib/test/test_faulthandler.py", line 460, in _check_dump_traceback_later
    self.assertRegex(trace, regex)
AssertionError: Regex didn't match: '^Timeout \\(0:00:00.500000\\)!\\nThread 0x[0-9a-f]+:\\n  File "<string>", line 9 in func\n  File "<string>", line 20 in <module>$' not found in 'Timeout (0:00:00.500000)!\nThread 0x00007fff7f242180:\n  File "<string>", line 10 in func\n  File "<string>", line 20 in <module>'
msg178352 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2012-12-28 00:17
Duplicate of #15971.
History
Date User Action Args
2012-12-28 00:17:06ezio.melottisetstatus: open -> closed

superseder: Sporadic failure in test_dump_tracebacks_later_file (test_faulthandler)

nosy: + ezio.melotti
messages: + msg178352
resolution: duplicate
stage: needs patch -> resolved
2012-12-28 00:01:46pitroucreate