classification
Title: Python Code module implements uncomputable function
Type: behavior Stage:
Components: Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: mark.dickinson, pleed
Priority: normal Keywords:

Created on 2012-12-22 06:17 by pleed, last changed 2012-12-22 11:14 by mark.dickinson. This issue is now closed.

Messages (2)
msg177923 - (view) Author: pleed (pleed) Date: 2012-12-22 06:17
The "code" class implements the __eq__ operator which is known to be uncomputable.
msg177936 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2012-12-22 11:14
Closing as invalid.  There's no issue with comparing code objects---__eq__ implements a perfectly good equivalence relation.  This is not an extensional definition of function equality.
History
Date User Action Args
2012-12-22 11:14:54mark.dickinsonsetstatus: open -> closed

nosy: + mark.dickinson
messages: + msg177936

resolution: not a bug
2012-12-22 06:17:34pleedcreate