classification
Title: IDLE problems with Mac OS 10.6.8 ("print syntax")
Type: Stage: resolved
Components: IDLE Versions: Python 3.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: r.david.murray, stephenhohs
Priority: normal Keywords:

Created on 2012-12-10 00:39 by stephenhohs, last changed 2012-12-10 02:49 by stephenhohs. This issue is now closed.

Messages (3)
msg177246 - (view) Author: stephenhohs (stephenhohs) Date: 2012-12-10 00:39
Numerous attempts were made to install (and deinstall) IDLE along with getting the recommended version of ActiveTCL.  IDLE will always give a print syntax error with one liners print "hello, world".  This is occurring for Mac OS 10.6.8
msg177255 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2012-12-10 02:43
The statement

    print "hello world" 

is indeed invalid syntax in Python3.
msg177256 - (view) Author: stephenhohs (stephenhohs) Date: 2012-12-10 02:49
You are right.

Thanks

Stephen M. Hohs

smhohs@aol.com
History
Date User Action Args
2012-12-10 02:49:49stephenhohssetmessages: + msg177256
2012-12-10 02:43:24r.david.murraysetstatus: open -> closed

nosy: + r.david.murray
messages: + msg177255

resolution: not a bug
stage: resolved
2012-12-10 00:39:36stephenhohscreate