classification
Title: mimetypes.py UnicodeDecodeError: 'ascii' codec can't decode byte 0xe0 in position 0: ordinal not in range(128)
Type: crash Stage:
Components: Unicode, Windows Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: mimetypes initialization fails on Windows because of non-Latin characters in registry
View: 9291
Assigned To: Nosy List: Vladimir.Kotulskiy, amaury.forgeotdarc, ezio.melotti
Priority: normal Keywords: patch

Created on 2012-12-05 17:05 by Vladimir.Kotulskiy, last changed 2012-12-05 17:23 by amaury.forgeotdarc. This issue is now closed.

Files
File name Uploaded Description Edit
mimetypes.patch Vladimir.Kotulskiy, 2012-12-05 17:05
Messages (2)
msg176990 - (view) Author: Vladimir Kotulskiy (Vladimir.Kotulskiy) Date: 2012-12-05 17:05
File "C:\DevTools\Python27\lib\mimetypes.py", line 355, in init
    db.read_windows_registry()
  File "C:\DevTools\Python27\lib\mimetypes.py", line 259, in read_windows_registry
    for ctype in enum_types(mimedb):
  File "C:\DevTools\Python27\lib\mimetypes.py", line 249, in enum_types
    ctype = ctype.encode(default_encoding) # omit in 3.x!
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe0 in position 0: ordinal not in range(128)
msg176994 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2012-12-05 17:23
This is a duplicate of issue9291.
History
Date User Action Args
2012-12-05 17:23:19amaury.forgeotdarcsetstatus: open -> closed

nosy: + amaury.forgeotdarc
messages: + msg176994

superseder: mimetypes initialization fails on Windows because of non-Latin characters in registry
resolution: duplicate
2012-12-05 17:05:26Vladimir.Kotulskiycreate