classification
Title: Can't install Python 3 on Redhat Linux, make failed
Type: compile error Stage:
Components: Installation Versions: Python 3.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: pitrou, stephenlqn@gmail.com
Priority: normal Keywords:

Created on 2012-11-15 16:29 by stephenlqn@gmail.com, last changed 2012-11-15 22:12 by pitrou. This issue is now closed.

Messages (4)
msg175623 - (view) Author: Stephen (stephenlqn@gmail.com) Date: 2012-11-15 16:29
Machine is Redhat Linux 6.2. Tried to install Python3.3 build failed in the make step.

-----------------------
[sliu@wtl-build-1 Python-3.3.0]$ uname -a    
Linux wtl-build-1 2.6.18-164.el5 #1 SMP Tue Aug 18 15:51:48 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
[sliu@wtl-build-1 Python-3.3.0]$ pwd
/tmp/Python-3.3.0
[snip]
config.status: pyconfig.h is unchanged
creating Modules/Setup
creating Modules/Setup.local
creating Makefile
[sliu@wtl-build-1 Python-3.3.0]$ make 
Wrapping make for user sliu on hostname wtl-build-1...
gcc: Parser/acceler.o: No such file or directory
gcc: Parser/grammar1.o: No such file or directory
gcc: Parser/listnode.o: No such file or directory
gcc: Parser/node.o: No such file or directory
gcc: Parser/parser.o: No such file or directory
gcc: Parser/bitset.o: No such file or directory
gcc: Parser/metagrammar.o: No such file or directory
gcc: Parser/firstsets.o: No such file or directory
gcc: Parser/grammar.o: No such file or directory
gcc: Parser/pgen.o: No such file or directory
gcc: Objects/obmalloc.o: No such file or directory
gcc: Python/dynamic_annotations.o: No such file or directory
gcc: Python/mysnprintf.o: No such file or directory
gcc: Python/pyctype.o: No such file or directory
gcc: Parser/tokenizer_pgen.o: No such file or directory
gcc: Parser/printgrammar.o: No such file or directory
gcc: Parser/parsetok_pgen.o: No such file or directory
gcc: Parser/pgenmain.o: No such file or directory
make[1]: *** [Parser/pgen] Error 1
make: *** [Include/graminit.h] Error 2
Build with args "" took 0 seconds, status complete
[sliu@wtl-build-1 Python-3.3.0]$ 

-----------------------

Tried different Linux machines, same error. Tried Python 3.3, 3.1 and 3.0, same error.

Any idea?
Stephen
msg175624 - (view) Author: Stephen (stephenlqn@gmail.com) Date: 2012-11-15 16:34
Sorry, missed the configure command in the previous message. It should have been:

-----------------------
[sliu@wtl-build-1 Python-3.3.0]$ uname -a    
Linux wtl-build-1 2.6.18-164.el5 #1 SMP Tue Aug 18 15:51:48 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
[sliu@wtl-build-1 Python-3.3.0]$ pwd
/tmp/Python-3.3.0
[sliu@wtl-build-1 Python-3.3.0]$ ./configure 
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for --enable-universalsdk... no
checking for --with-universal-archs... 32-bit
checking MACHDEP... linux
checking for --without-gcc... no
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for --with-cxx-main=<compiler>... no
checking for g++... no
configure: WARNING:

  By default, distutils will build C++ extension modules with "g++".
  If this is not intended, then set CXX on the configure command line.
  
checking for -Wl,--no-as-needed... yes
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
[snip]
config.status: pyconfig.h is unchanged
creating Modules/Setup
creating Modules/Setup.local
creating Makefile
[sliu@wtl-build-1 Python-3.3.0]$ make 
Wrapping make for user sliu on hostname wtl-build-1...
gcc: Parser/acceler.o: No such file or directory
gcc: Parser/grammar1.o: No such file or directory
gcc: Parser/listnode.o: No such file or directory
gcc: Parser/node.o: No such file or directory
gcc: Parser/parser.o: No such file or directory
gcc: Parser/bitset.o: No such file or directory
gcc: Parser/metagrammar.o: No such file or directory
gcc: Parser/firstsets.o: No such file or directory
gcc: Parser/grammar.o: No such file or directory
gcc: Parser/pgen.o: No such file or directory
gcc: Objects/obmalloc.o: No such file or directory
gcc: Python/dynamic_annotations.o: No such file or directory
gcc: Python/mysnprintf.o: No such file or directory
gcc: Python/pyctype.o: No such file or directory
gcc: Parser/tokenizer_pgen.o: No such file or directory
gcc: Parser/printgrammar.o: No such file or directory
gcc: Parser/parsetok_pgen.o: No such file or directory
gcc: Parser/pgenmain.o: No such file or directory
make[1]: *** [Parser/pgen] Error 1
make: *** [Include/graminit.h] Error 2
Build with args "" took 0 seconds, status complete
[sliu@wtl-build-1 Python-3.3.0]$ 

-----------------------
msg175649 - (view) Author: Stephen (stephenlqn@gmail.com) Date: 2012-11-15 21:55
Please ignore this. I have figured out it was caused by our company's make wrapper. Using native "make" works like a charm.
msg175652 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2012-11-15 22:12
Ok, closing then.
History
Date User Action Args
2012-11-15 22:12:25pitrousetstatus: open -> closed

nosy: + pitrou
messages: + msg175652

resolution: not a bug
2012-11-15 21:55:30stephenlqn@gmail.comsetmessages: + msg175649
2012-11-15 16:34:07stephenlqn@gmail.comsetmessages: + msg175624
2012-11-15 16:29:20stephenlqn@gmail.comcreate