classification
Title: Mostly for discussion: _winapi as builtin for bootstrapping distutils.
Type: behavior Stage:
Components: Versions: Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Ray.Donnelly, pitrou, sbt
Priority: normal Keywords: patch

Created on 2012-11-11 21:49 by Ray.Donnelly, last changed 2012-11-12 00:11 by sbt. This issue is now closed.

Files
File name Uploaded Description Edit
_winapi_as_builtin_for_distutils_bootstrap.patch Ray.Donnelly, 2012-11-11 21:49 Compile _winapi as a builtin rather than a standalone module.
Messages (3)
msg175393 - (view) Author: Ray Donnelly (Ray.Donnelly) * Date: 2012-11-11 21:49
I'm submitting this patch as it was suggested I do so by Antoine Pitrou on #python-dev. As such, it's more a point of discussion than a patch I'm trying to get merged (for one thing, my build is a MinGW GCC compiled and I've not considered the MSVC Windows build).

I ran into a problem with a customisation I made to cygwinccompiler.py where I wanted to use Popen to ask gcc where it's ld is:

out = Popen(gcc+' --print-prog-name ld', shell=True, stdout=PIPE).stdout

This has worked fine before on 2.7.3, but with 3.3.0, subprocess can't be imported as _winapi isn't builtin, instead, it's built by setup.py as a module.

So is this the right thing to do? Or is distutils not supposed to use subprocess during bootstrapping?
msg175405 - (view) Author: Richard Oudkerk (sbt) * (Python committer) Date: 2012-11-11 22:54
The patch does not apply correctly against vanilla Python 3.3.  I would guess that you are using a version of Python which has been patched to add mingw support.  Where did you get it from?

(In vanilla Python 3.3, setup.py does not contain any mention of _winapi.c.)
msg175407 - (view) Author: Ray Donnelly (Ray.Donnelly) * Date: 2012-11-11 23:28
I should have checked the situation better, it is indeed towards the back end of a series of patches to enable MinGW compilation, so the issue is irrelevant without the preceding patches.

Sorry for the noise.
History
Date User Action Args
2012-11-12 00:11:52sbtsetstatus: open -> closed
2012-11-11 23:28:46Ray.Donnellysetresolution: not a bug
messages: + msg175407
2012-11-11 22:54:45sbtsetmessages: + msg175405
2012-11-11 21:49:34Ray.Donnellycreate