classification
Title: Template strings documentation in Python 3 refers to % substitution in present tense
Type: Stage:
Components: Documentation Versions: Python 3.1, Python 3.2, Python 3.3, Python 3.4
process
Status: closed Resolution: wont fix
Dependencies: Superseder:
Assigned To: docs@python Nosy List: Ramchandra Apte, andrewsg, docs@python, georg.brandl, serhiy.storchaka
Priority: normal Keywords:

Created on 2012-11-07 21:28 by andrewsg, last changed 2013-04-06 00:24 by andrewsg. This issue is now closed.

Messages (5)
msg175123 - (view) Author: Andrew Gorcester (andrewsg) * Date: 2012-11-07 21:28
Documentation here: http://docs.python.org/3/library/string.html#template-strings says "Instead of the normal %-based substitutions, Templates support $-based substitutions..."

I believe it is confusing to refer to %-based substitutions in a way that implies they still exist in Python 3.  It would be better to fix this to either refer to {} substitution or to remove the reference comparing it to normal string substitution altogether.
msg175125 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2012-11-07 21:59
Who said % substitution doesn't exist anymore in Python 3?

That said, it's certainly not wrong to replace this with {} substitution.
msg175126 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2012-11-07 22:08
There is not a bug.  %-based substitutions exist in Python 3.

http://docs.python.org/3/library/stdtypes.html#printf-style-string-formatting
msg175132 - (view) Author: Andrew Gorcester (andrewsg) * Date: 2012-11-08 00:41
Sorry, my mistake -- I thought that %-based formatting had been deprecated and removed by now, because it wasn't documented in library/string.html .  However, I still think referring to %-based formatting as "normal" in Python 3 is confusing to readers as it is not the preferred system.
msg181034 - (view) Author: Ramchandra Apte (Ramchandra Apte) * Date: 2013-01-31 16:02
> ... as it is not the preferred system.
I prefer .format() but I don't think that's true for many people.
History
Date User Action Args
2013-04-06 00:24:45andrewsgsetstatus: open -> closed
resolution: wont fix
2013-01-31 16:02:17Ramchandra Aptesetnosy: + Ramchandra Apte
messages: + msg181034
2012-11-08 00:41:57andrewsgsetmessages: + msg175132
2012-11-07 22:08:17serhiy.storchakasetnosy: + serhiy.storchaka
messages: + msg175126
2012-11-07 21:59:35georg.brandlsetnosy: + georg.brandl
messages: + msg175125
2012-11-07 21:28:24andrewsgcreate