classification
Title: eventlet.monkey_patch() breaks subprocess.Popen on Windows
Type: behavior Stage: resolved
Components: Interpreter Core, IO, Library (Lib) Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: alexpilotti, r.david.murray
Priority: normal Keywords:

Created on 2012-11-05 15:26 by alexpilotti, last changed 2012-11-05 15:58 by r.david.murray. This issue is now closed.

Messages (2)
msg174915 - (view) Author: Alessandro Pilotti (alexpilotti) Date: 2012-11-05 15:26
eventlet.monkey_patch() breaks subprocess.Popen on Windows with error:

NotImplementedError: set_nonblocking() on a file object with no setblocking() method (Windows pipes don't support non-blocking I/O)

Here's the full stack trace:
http://paste.openstack.org/show/24032/

Workaround: eventlet.monkey_patch(os=False)
msg174917 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2012-11-05 15:58
eventlet is not a part of the Python standard library.  Please report this bug to the project's bug tracker.
History
Date User Action Args
2012-11-05 15:58:13r.david.murraysetstatus: open -> closed

nosy: + r.david.murray
messages: + msg174917

resolution: not a bug
stage: resolved
2012-11-05 15:26:24alexpilotticreate