classification
Title: IDLE for Windows 8
Type: behavior Stage:
Components: IDLE, Installation, Windows Versions: Python 3.3
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: amundell, brian.curtin, evilpandas, jabhijeet, loewis, roger.serwy, tim.golden
Priority: normal Keywords:

Created on 2012-10-30 19:21 by jabhijeet, last changed 2013-03-11 07:11 by evilpandas. This issue is now closed.

Messages (8)
msg174217 - (view) Author: Abhijeet Joshi (jabhijeet) Date: 2012-10-30 19:21
Hello,

I have installed Idle for python 3.3 on windows 8 and trying to open the GUI but unable to open anything.
The screen doesn't show up on monitor.

Please help me here.

Thanks
Abhijeet
msg174223 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2012-10-30 20:29
Can you launch Python from a command line and then launch IDLE from there?

    cd c:\python33
    python

After python starts, enter the following:

    import idlelib.idle
msg174224 - (view) Author: Abhijeet Joshi (jabhijeet) Date: 2012-10-30 20:36
Thanks for your reply.

I have tried re-installing it 3-4 times and it started working now.
msg174228 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2012-10-30 21:15
I wonder if there is a bug in the Python installer on the new Windows 8 platform, though it is unlikely. 

I will leave this issue open for Windows 8 developers to comment. (I don't have Win8 for testing just yet.) Feel free to close.
msg174229 - (view) Author: Abhijeet Joshi (jabhijeet) Date: 2012-10-30 21:28
will leave it open so that some win8 developer will check it out.
msg174266 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2012-10-31 08:00
Unfortunately, there is not much to check now that you got it working. Doing what Roger first asked for might have given insights, but we can now not determine the issue anymore.

So closing this as "works for me".
msg177876 - (view) Author: Andrew Mundell (amundell) Date: 2012-12-21 13:30
I had a similar issue in Win8, but occured after installing another program. My issue was related to the TCL_Library environment variable. If it is related to this error it can be confirmed by opening the command prompt, changing dir to cd c:\python33\ and typing python. Once python has started write import idlelib.idle. If idle does not start, read the errors and check to see if a TCL-related error has been generated. If this error has occured change the environment variable (ControlPanel\right click System\change settings\advanced tab\environment variable\select TCL_Library. Alter the the path to C:\Python33\tcl\tcl8.5. idle should then start. However you may have issues/conflict with other installed programs that access the TCL_Library. Hope this helps.
msg183938 - (view) Author: j s (evilpandas) Date: 2013-03-11 07:11
I had this issue too, I realised that I had installed the 32bit version on a machine running 64bit. So I uninstalled and installed the 64bit and it's fine now.
History
Date User Action Args
2013-03-11 07:11:04evilpandassetnosy: + evilpandas
messages: + msg183938
2012-12-21 13:30:19amundellsetnosy: + amundell
messages: + msg177876
2012-10-31 08:00:34loewissetstatus: open -> closed

nosy: + loewis
messages: + msg174266

resolution: works for me
2012-10-30 21:28:44jabhijeetsetmessages: + msg174229
2012-10-30 21:15:03roger.serwysetnosy: + tim.golden, brian.curtin
messages: + msg174228
components: + Installation, Windows
2012-10-30 20:36:19jabhijeetsetmessages: + msg174224
2012-10-30 20:29:34roger.serwysetnosy: + roger.serwy
messages: + msg174223
2012-10-30 19:21:39jabhijeetcreate