classification
Title: Error call
Type: Stage: resolved
Components: None Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: James.Lu, r.david.murray
Priority: normal Keywords:

Created on 2012-10-28 23:18 by James.Lu, last changed 2012-10-29 00:15 by r.david.murray. This issue is now closed.

Messages (3)
msg174086 - (view) Author: James Lu (James.Lu) * Date: 2012-10-28 23:18
>>>x="y"
>>>y=x
>>>x=y
>>>print x
x
>>>print y
x
It should raise a RuntimeError
msg174087 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2012-10-28 23:34
It should print 'y'.  And it does for me.

If you have questions about this, you might want to try the python-tutors list.
msg174088 - (view) Author: James Lu (James.Lu) * Date: 2012-10-28 23:42
srry
History
Date User Action Args
2012-10-29 00:15:30r.david.murraysetresolution: rejected -> not a bug
2012-10-28 23:42:51James.Lusetresolution: not a bug -> rejected
messages: + msg174088
2012-10-28 23:34:55r.david.murraysetstatus: open -> closed

type: performance ->

nosy: + r.david.murray
messages: + msg174087
resolution: not a bug
stage: resolved
2012-10-28 23:19:47James.Lusetversions: - Python 2.6
2012-10-28 23:18:19James.Lucreate