classification
Title: pysnmp/asyncore - timeout ineffective?
Type: behavior Stage: resolved
Components: None Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Trenton.Craig, neologix
Priority: normal Keywords:

Created on 2012-10-27 16:45 by Trenton.Craig, last changed 2012-11-07 19:07 by neologix. This issue is now closed.

Messages (3)
msg173940 - (view) Author: Trenton Craig (Trenton.Craig) Date: 2012-10-27 16:45
I have an application that is set to use pysnmp to obtain sysDescription and system names from devices on our network.  Currently, we are using python 2.6.2, due to the limitations of the box (solaris), and it works fine.

However, our new environment uses python2.7.3, and ubuntu, and the timeout attribute appears to be failing.

Not sure if this is a bug with pysnmp or asyncore.

I apologize for the brevity of the situation, but will be happy to provide more details upon request.
msg174124 - (view) Author: Trenton Craig (Trenton.Craig) Date: 2012-10-29 16:26
So, in testing, we reset retries to 1 instead of 0, and on our ubuntu environment this allows it to function.  So issue is not with timeout, but with the retries variable.
msg174213 - (view) Author: Charles-François Natali (neologix) * (Python committer) Date: 2012-10-30 18:30
It's a little too vague :-)

You should probably report this on pysnmp mailing list.
If you want to debug this, you should perform a tcpdump/wireshark capture while running your script, and see what happens (according to your description, it may simply be that the remote snmp agent takes too long to answer, maybe because of a loaded machine, crappy network, of NFS mounts timeouts on the target host).
History
Date User Action Args
2012-11-07 19:07:51neologixsetstatus: open -> closed
resolution: not a bug
stage: resolved
2012-10-30 18:30:02neologixsetnosy: + neologix
messages: + msg174213
2012-10-29 16:26:53Trenton.Craigsetmessages: + msg174124
2012-10-27 16:45:00Trenton.Craigcreate