classification
Title: Rare exception in test_urllib2net
Type: crash Stage:
Components: Versions: Python 2.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: nnorwitz Nosy List: gregory.p.smith, gvanrossum, nnorwitz
Priority: normal Keywords:

Created on 2007-12-13 21:07 by gvanrossum, last changed 2008-01-24 07:46 by nnorwitz. This issue is now closed.

Messages (4)
msg58588 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2007-12-13 21:07
test test_urllib2net failed -- Traceback (most recent call last):
 File "/tmp/python-test/local/lib/python2.6/test/test_urllib2net.py",
line 175, in test_ftp
   self._test_urls(urls, self._extra_handlers())
 File "/tmp/python-test/local/lib/python2.6/test/test_urllib2net.py",
line 244, in _test_urls
   f = urllib2.urlopen(url, req)
 File "/tmp/python-test/local/lib/python2.6/urllib2.py", line 124, in
urlopen
   return _opener.open(url, data, timeout)
 File "/tmp/python-test/local/lib/python2.6/urllib2.py", line 380, in open
   response = self._open(req, data)
 File "/tmp/python-test/local/lib/python2.6/urllib2.py", line 398, in _open
   '_open', req)
 File "/tmp/python-test/local/lib/python2.6/urllib2.py", line 358, in
_call_chain
   result = func(*args)
 File "/tmp/python-test/local/lib/python2.6/urllib2.py", line 1277, in
ftp_open
   fw = self.connect_ftp(user, passwd, host, port, dirs, req.timeout)
 File "/tmp/python-test/local/lib/python2.6/urllib2.py", line 1323, in
connect_ftp
   self.cache[key] = ftpwrapper(user, passwd, host, port, dirs, timeout)
 File "/tmp/python-test/local/lib/python2.6/urllib.py", line 842, in
__init__
   self.init()
 File "/tmp/python-test/local/lib/python2.6/urllib.py", line 848, in init
   self.ftp.connect(self.host, self.port, self.timeout)
 File "/tmp/python-test/local/lib/python2.6/ftplib.py", line 129, in connect
   self.sock = socket.create_connection((self.host, self.port),
self.timeout)
 File "/tmp/python-test/local/lib/python2.6/socket.py", line 462, in
create_connection
   raise error, msg
TypeError: __init__() takes exactly 2 arguments (3 given)

It looks like somehow msg is a 2-tuple here.  What exception could have
been caught?
msg58593 - (view) Author: Neal Norwitz (nnorwitz) * (Python committer) Date: 2007-12-13 21:49
This may happen every time on the MIPS buildbot.  Here is a recent run.

http://www.python.org/dev/buildbot/all/MIPS%20Debian%20trunk/builds/190/step-test/0

My guess is that there is some exception happening in C code and that
propagates back up to the error we see.  I could never find the root
cause when I tried to trace I down though.
msg58595 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2007-12-13 22:09
Can you log in to the box and reproduce it manually?

On Dec 13, 2007 1:49 PM, Neal Norwitz <report@bugs.python.org> wrote:
>
> Neal Norwitz added the comment:
>
> This may happen every time on the MIPS buildbot.  Here is a recent run.
>
> http://www.python.org/dev/buildbot/all/MIPS%20Debian%20trunk/builds/190/step-test/0
>
> My guess is that there is some exception happening in C code and that
> propagates back up to the error we see.  I could never find the root
> cause when I tried to trace I down though.
>
> ----------
> nosy: +nnorwitz
>
>
> __________________________________
> Tracker <report@bugs.python.org>
> <http://bugs.python.org/issue1617>
> __________________________________
>
msg61621 - (view) Author: Neal Norwitz (nnorwitz) * (Python committer) Date: 2008-01-24 07:46
This started happening consistently on my box and I was able to
reproduce it.  Revision 60233 should fix this problem.  I forwarded the
checkin to Greg.  Hopefully he can comment if there is a problem.  (Also
cc'd him on this bug report that I'm now closing.)
History
Date User Action Args
2008-01-24 07:46:24nnorwitzsetstatus: open -> closed
assignee: nnorwitz
resolution: fixed
messages: + msg61621
nosy: + gregory.p.smith
2007-12-13 22:09:13gvanrossumsetmessages: + msg58595
2007-12-13 21:49:17nnorwitzsetnosy: + nnorwitz
messages: + msg58593
2007-12-13 21:07:48gvanrossumcreate