classification
Title: Closing Debugger freezes IDLE shell
Type: Stage:
Components: IDLE Versions: Python 3.2, Python 3.3
process
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE - shell becomes unresponsive if debugger windows is closed while active.
View: 15348
Assigned To: Nosy List: jimbo1qaz, roger.serwy
Priority: normal Keywords:

Created on 2012-10-07 23:19 by jimbo1qaz, last changed 2012-10-08 00:14 by roger.serwy. This issue is now closed.

Messages (3)
msg172352 - (view) Author: jimbo1qaz (jimbo1qaz) Date: 2012-10-07 23:19
Open a Python file with IDLE and F5 it. Turn on debugger ([DEBUG ON]), F5 again ([DEBUG ON]), and close the debugger ([DEBUG OFF]). The shell is now completely locked and must be closed (with a 'The program is still running, want to kill it?' message).
msg172353 - (view) Author: jimbo1qaz (jimbo1qaz) Date: 2012-10-07 23:21
I have confirmed that this happens on both 3.2 and .3, and it also happens when you close any active debug window.
msg172354 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2012-10-08 00:14
Hi Jimbo,

Clicking "quit" first avoids this problem, but I do agree that it does need to be fixed.

This is also a duplicate of issue15348. I am closing this issue in favor of that one. Please feel free to add yourself to the nosy list on that issue.
History
Date User Action Args
2012-10-08 00:14:19roger.serwysetstatus: open -> closed

nosy: + roger.serwy
messages: + msg172354

superseder: IDLE - shell becomes unresponsive if debugger windows is closed while active.
resolution: duplicate
2012-10-07 23:21:07jimbo1qazsetmessages: + msg172353
versions: + Python 3.2
2012-10-07 23:19:18jimbo1qazcreate