classification
Title: sporadic test_multiprocessing failure
Type: behavior Stage:
Components: Library (Lib), Tests Versions: Python 3.2, Python 3.3, Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: pitrou, sbt, trent, vstinner
Priority: normal Keywords:

Created on 2012-10-07 17:55 by pitrou, last changed 2013-11-18 08:32 by vstinner. This issue is now closed.

Messages (2)
msg172325 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2012-10-07 17:55
Seen on a buildbot:

======================================================================
FAIL: test_mymanager_context_prestarted (test.test_multiprocessing.WithManagerTestMyManager)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Volumes/bay2/buildslave/cpython/3.3.snakebite-mountainlion-amd64/build/Lib/test/test_multiprocessing.py", line 1911, in test_mymanager_context_prestarted
    self.assertEqual(manager._process.exitcode, 0)
AssertionError: None != 0

http://buildbot.python.org/all/builders/AMD64%20Mountain%20Lion%20%5BSB%5D%203.3/builds/35/steps/test/logs/stdio
msg203256 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2013-11-18 08:32
I didn't see this failure recently. The issue doesn't contain useful information, and has no activity since more than 1 year, so I'm closing it. Reopen the issue with more information if it was reproduced recently.
History
Date User Action Args
2013-11-18 08:32:22vstinnersetstatus: open -> closed

nosy: + vstinner
messages: + msg203256

resolution: not a bug
2012-10-07 17:55:36pitroucreate