classification
Title: Compiling vim with Python 3.3 support fails
Type: compile error Stage: resolved
Components: Windows Versions: Python 3.3
process
Status: closed Resolution: third party
Dependencies: Superseder:
Assigned To: Nosy List: matrixise, r.david.murray, steve.dower, v_core, zach.ware
Priority: normal Keywords:

Created on 2012-10-01 14:45 by v_core, last changed 2019-05-14 18:39 by zach.ware. This issue is now closed.

Messages (7)
msg171722 - (view) Author: Sascha (v_core) Date: 2012-10-01 14:45
Hello there,
I hope I'm right here.

I tried to compile vim with Python 3.3 32bit support.
OS: Windows 7 64bit
Compiler: MinGW
Compiling vim with Python 3.2 32bit support works!

The error message:
obj/if_python3.o:if_python3.c:(.text+0x739): undefined reference to `__imp__PyUnicode_AsUnicode'
msg171727 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2012-10-01 15:55
We don't currently support mingw, and I don't think any of our active developers have experience with it.  If this actually worked in 3.2 then the fix *might* be relatively easy.  Hopefully you or someone else will be interested enough to work out a patch.
msg171729 - (view) Author: Sascha (v_core) Date: 2012-10-01 16:05
Actually I'd have no problem using 3.2

Though with 3.2 I got the problem described here: https://groups.google.com/forum/?fromgroups=#!topic/vim_dev/5MYb23t9ZBM

I was hoping this is fixed in 3.3, but now I can't even compile it
msg171730 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2012-10-01 16:21
Well, that looks like a bug in VIM, not Python.  Though if that order of calls is required and it is not documented, that would be a doc bug (especially if it used to work in the other order in python2.)
msg224272 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-07-29 23:41
I don't see how we can do anything with this as mingw is unsupported.  If any docs need changing wouldn't that best be done as a completely separate issue?
msg342496 - (view) Author: St├ęphane Wirtel (matrixise) * (Python committer) Date: 2019-05-14 18:19
Hi,

The used version in this issue is outdated we could close this issue but I prefer to get the feedback from Steve Dower and Zach Ware. If this issue is not relevant to 3.7+, I suggest closing this issue.
msg342500 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2019-05-14 18:39
As this appears to be a bug in Vim on an unsupported configuration with a now-unsupported version of Python, I'm closing the issue.  If this is still an issue with a modern version of Python in a supported environment and can be shown to be a bug in Python rather than Vim, a new issue can be opened.
History
Date User Action Args
2019-05-14 18:39:18zach.waresetversions: - Python 3.7, Python 3.8
2019-05-14 18:39:05zach.waresetstatus: open -> closed
resolution: third party
messages: + msg342500

stage: resolved
2019-05-14 18:19:09matrixisesetnosy: + matrixise, zach.ware, steve.dower

messages: + msg342496
versions: + Python 3.7, Python 3.8
2019-04-26 20:12:43BreamoreBoysetnosy: - BreamoreBoy
2014-07-29 23:41:33BreamoreBoysetnosy: + BreamoreBoy
messages: + msg224272
2012-10-01 16:21:46r.david.murraysetmessages: + msg171730
2012-10-01 16:05:56v_coresetmessages: + msg171729
2012-10-01 15:55:37r.david.murraysetnosy: + r.david.murray
messages: + msg171727
2012-10-01 14:45:58v_corecreate