classification
Title: [OS bug] DragonFly buildbot locale failures
Type: behavior Stage: resolved
Components: Versions: Python 3.3
process
Status: closed Resolution: wont fix
Dependencies: Superseder:
Assigned To: Nosy List: skrah, trent
Priority: low Keywords: buildbot

Created on 2012-09-23 16:17 by skrah, last changed 2012-09-24 13:33 by skrah. This issue is now closed.

Messages (2)
msg171052 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2012-09-23 16:17
The locale failures on the DragonFly buildbot are caused by an OS bug:

bugs.dragonflybsd.org/issues/2415


I'm opening an issue so that this is recorded and other people hopefully
won't waste time debugging the failures. I intend to close the issue
as invalid in a couple of days.

======================================================================
FAIL: test_wide_char_separator_decimal_point (test.test_decimal.CFormatTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/cpython/buildslave/3.x.snakebite-dragonfly30-amd64-1/build/Lib/test/test_decimal.py", line 1149, in test_wide_char_separator_decimal_point
    '100\u066c000\u066c000\u066b123')
AssertionError: '100000000.123' != '100\u066c000\u066c000\u066b123'
- 100000000.123
?          ^
+ 100\u066c000\u066c000\u066b123
?    +   +   ^


======================================================================
ERROR: test_basic (test.test_strptime.getlang_Tests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/cpython/buildslave/3.x.snakebite-dragonfly30-amd64-1/build/Lib/test/test_strptime.py", line 16, in test_basic
    self.assertEqual(_strptime._getlang(), locale.getlocale(locale.LC_TIME))
  File "/home/cpython/buildslave/3.x.snakebite-dragonfly30-amd64-1/build/Lib/_strptime.py", line 31, in _getlang
    return locale.getlocale(locale.LC_TIME)
  File "/home/cpython/buildslave/3.x.snakebite-dragonfly30-amd64-1/build/Lib/locale.py", line 524, in getlocale
    return _parse_localename(localename)
  File "/home/cpython/buildslave/3.x.snakebite-dragonfly30-amd64-1/build/Lib/locale.py", line 433, in _parse_localename
    raise ValueError('unknown locale: %s' % localename)
ValueError: unknown locale: ps_AF
msg171124 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2012-09-24 13:33
Closing since this an OS bug.
History
Date User Action Args
2012-09-24 13:33:05skrahsetstatus: open -> closed
resolution: wont fix
messages: + msg171124

stage: resolved
2012-09-23 16:17:26skrahcreate