classification
Title: Python GUI idle not working
Type: behavior Stage:
Components: IDLE Versions: Python 3.2
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: ned.deily, roger.serwy, sreeni, terry.reedy
Priority: normal Keywords:

Created on 2012-09-21 10:30 by sreeni, last changed 2012-09-24 14:23 by roger.serwy. This issue is now closed.

Messages (5)
msg170877 - (view) Author: Sreenivas (sreeni) Date: 2012-09-21 10:30
Hi Everybody,

I have a problem where Python GUI IDLE is not working.I did go through the issues 15658,9925,4625.I did follow the steps given in these issues.I did unset the tcl and tk_library.I was able to open the python idle temporarily.But once i closed it I had to follow the same commands to open it again.instead of just clicking the application.I also tried this command --------- c:\>Python32\Lib\idlelib\idle.py

This command gave the following error message

"This probably means Tcl wasn#t properly installed"

I tried to uninstall and reinstall and Python32 but still unsuccessful.I have installed few libs such as cx_Freeze and serial.I do not want to lose them as serial lib was itself painstaking process for installation.Can you tell me stepwise as to what should I do to get the IDLE working.

regards,
Sreeni
msg170896 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2012-09-21 15:16
Hi Sreeni, 

Can you launch a Python interpreter from C:\python32\python.exe and report the output to "import tkinter" ?
msg170939 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2012-09-22 00:21
The following might also be helpful: which version of Windows? 32 or 64 bit? is python the 32 or 64 bit build? Or just copy the header line from the interactive interpreter. For me:

Python 3.3.0rc2 (v3.3.0rc2:88a0792e8ba3, Sep  9 2012, 10:13:38) [MSC v.1600 64 bit (AMD64)] on win32

(although the win32 part seems wrong as this is 64 bit windows and amd64 build would not run on 32 bit windows)

Another suggestion: get 3.3.0, install in /python33, and try that (you should be able to select an option to have it not be the default install). This should not affect your 3.2 installation, and it will install its own copy of tcl/tk. In fact, if you do not have 3.2.3, you should be able to install that without disturbing your installed libraries.
msg171107 - (view) Author: Sreenivas (sreeni) Date: 2012-09-24 09:36
Hi All,

I was able to solve the problem.I reinstalled the python overwriting the lib packages of the previously installed Python.I was not overwriting it before because I was afraid that I would lose my pyserial and cx_Freeze lib files.But it was still there and was not deleted :).Thanks guys for your help and answers.I wish I get some other issue and get back to the forum asap.

cheers,
Sreeni
msg171141 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2012-09-24 14:23
A re-install fixed the issue for OP caused by what appeared to be a corrupt /Lib directory. I'm closing this issue.
History
Date User Action Args
2012-09-24 14:23:44roger.serwysetstatus: open -> closed
resolution: works for me
messages: + msg171141
2012-09-24 09:36:03sreenisetmessages: + msg171107
2012-09-22 00:22:05terry.reedysetstatus: pending -> open

messages: + msg170939
2012-09-21 15:16:34roger.serwysetstatus: open -> pending
type: crash -> behavior
messages: + msg170896
2012-09-21 14:03:47ezio.melottisetnosy: + terry.reedy, ned.deily, roger.serwy
2012-09-21 10:30:30sreenicreate