classification
Title: urllib2 always sends header connection: close
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 2.7, Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Cannot override 'connection: close' in urllib2 headers
View: 12849
Assigned To: Nosy List: r.david.murray, sanxiago
Priority: normal Keywords:

Created on 2012-09-14 10:47 by sanxiago, last changed 2012-09-14 13:26 by r.david.murray. This issue is now closed.

Messages (2)
msg170473 - (view) Author: Santiago Velasco (sanxiago) Date: 2012-09-14 10:47
I have noticed that urllib2 will always send the 'connection: close' in the headers, looking at the code there is no way to override this from outside of the open method.

 I am currently working with a server that kills connection upon reading the header, and content will not get served, or only a partial bit of the content gets served, I have tried with several other agents, all are able to download the full content served by the server.

I created a modified version without the 'connection: close' header and that solved the problem for me. I do not always have problems with that header, but I would like the ability to define my own headers, and since the connection: close header gets slapped inside an objects internal method, there is currently no other way I can bypass it.
msg170475 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2012-09-14 13:26
This is a duplicate of issue 12849.  I'm not sure that we support keep-alive using urllib.  We do using httplib, if I understand correctly.
History
Date User Action Args
2012-09-14 13:26:21r.david.murraysetstatus: open -> closed

superseder: Cannot override 'connection: close' in urllib2 headers

nosy: + r.david.murray
messages: + msg170475
resolution: duplicate
stage: resolved
2012-09-14 10:47:08sanxiagocreate