classification
Title: PyType_FromSpecWithBases bugfix
Type: behavior Stage: resolved
Components: Interpreter Core Versions: Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Robin.Schreiber, belopolsky, jcea, loewis, vstinner
Priority: normal Keywords: pep3121

Created on 2012-08-19 13:12 by Robin.Schreiber, last changed 2020-12-18 00:52 by vstinner. This issue is now closed.

Files
File name Uploaded Description Edit
PyType_FromSpecWithBases_bases_fix.patch Robin.Schreiber, 2012-08-19 13:12
Messages (3)
msg168570 - (view) Author: Robin Schreiber (Robin.Schreiber) * (Python triager) Date: 2012-08-19 13:12
This small patch prevents PyType_FromSpecWithBases, from setting the base(s) attribute of the HeapType to NULL-values.
msg170156 - (view) Author: Alexander Belopolsky (belopolsky) * (Python committer) Date: 2012-09-10 03:05
Why is this a problem? ISTM all that is happening is that null tp_base is set to null if Py_tp_base slot is specified as null.  If this is somehow a problem - the user should not specify Py_tp_base slot.
msg383284 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-12-18 00:52
Tons of extension modules have been ported to the multiphase initialization API (PEP 489) in bpo-1635741 without this fix. I don't think that it's needed.
History
Date User Action Args
2020-12-18 00:52:15vstinnersetstatus: open -> closed

nosy: + vstinner
messages: + msg383284

resolution: not a bug
stage: resolved
2012-11-08 13:22:02Robin.Schreibersetkeywords: + pep3121, - patch
2012-09-10 03:05:35belopolskysetnosy: + belopolsky
messages: + msg170156
2012-09-10 02:28:15jceasetnosy: + jcea
2012-08-19 13:17:55Robin.Schreibersetnosy: + loewis
2012-08-19 13:12:34Robin.Schreibercreate