classification
Title: PEP 3121, 384 Refactoring applied to select module
Type: resource usage Stage: resolved
Components: Extension Modules Versions: Python 3.4
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Make select module PEP-384 compatible
View: 38116
Assigned To: Nosy List: Robin.Schreiber, vstinner
Priority: normal Keywords: pep3121

Created on 2012-08-16 21:01 by Robin.Schreiber, last changed 2020-06-22 09:28 by vstinner. This issue is now closed.

Files
File name Uploaded Description Edit
select_pep3121-384_v0.patch Robin.Schreiber, 2012-08-16 21:01
Messages (2)
msg168410 - (view) Author: Robin Schreiber (Robin.Schreiber) * (Python triager) Date: 2012-08-16 21:01
Changes proposed in PEP3121 and PEP384 have now been applied to the select module!
msg372069 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-06-22 09:28
Fixed by:

New changeset f919054e539a5c1afde1b31c9fd7a8f5b2313311 by Dino Viehland in branch 'master':
bpo-38116: Convert select module to PEP-384 (#15971)
https://github.com/python/cpython/commit/f919054e539a5c1afde1b31c9fd7a8f5b2313311

I mark this issue as a duplicate of bpo-38116.
History
Date User Action Args
2020-06-22 09:28:36vstinnersetstatus: open -> closed

superseder: Make select module PEP-384 compatible

nosy: + vstinner
messages: + msg372069
resolution: duplicate
stage: resolved
2012-11-08 13:45:02Robin.Schreibersetkeywords: + pep3121, - patch
2012-08-27 03:49:13belopolskylinkissue15787 dependencies
2012-08-16 21:01:09Robin.Schreibercreate