classification
Title: python 2.5 install can't find tcl/tk in /usr/lib64
Type: behavior Stage: resolved
Components: Installation Versions: Python 2.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Add sys.platlibdir and configure --with-platlibdir to use /usr/lib64 on Fedora and SuSE
View: 1294959
Assigned To: Nosy List: ajaksu2, dstrozzi
Priority: normal Keywords:

Created on 2006-09-06 04:59 by dstrozzi, last changed 2009-03-30 03:23 by ajaksu2. This issue is now closed.

Messages (2)
msg60995 - (view) Author: David Strozzi (dstrozzi) Date: 2006-09-06 04:59
Hi,

I'm trying to compile python 2.5 RC1 under opensuse
10.1 on a 64-bit AMD athlon.  Although the README says
it will auto-detect tcl/tk, and setup tkinter
appropriately, it doesn't.  Among other things, this
means idle can't use this python version.  I have
tcl/tk, the libraries, devel packages, anything that
seemed relevant in YaST installed. I think the problem
is my tcl/tk libs live in /usr/lib64.  It seems, based
on the file Modules/Setup generated by ./configure,
that the python installer doesn't see these libs.

From perusing the web there seems to be a fair amount
of pain caused by /lib vs /lib64 dir names.  In fact an
older post to the forum identifies the same issue (just
search for lib64 if this link is busted):

http://sourceforge.net/tracker/index.php?func=detail&aid=1294959&group_id=5470&atid=105470

It would be very nice if this were somehow handled
automatically, or at least give detailed instructions
in the README (search the doc for lib64 returns nothing).

Cheers,
David
msg84480 - (view) Author: Daniel Diniz (ajaksu2) * (Python triager) Date: 2009-03-30 03:23
Closing as duplicate of issue 1294959.
History
Date User Action Args
2009-03-30 03:23:22ajaksu2setstatus: open -> closed

superseder: Add sys.platlibdir and configure --with-platlibdir to use /usr/lib64 on Fedora and SuSE
type: behavior

nosy: + ajaksu2
messages: + msg84480
resolution: duplicate
stage: resolved
2006-09-06 04:59:55dstrozzicreate