classification
Title: index entries not showing up in glossary
Type: behavior Stage:
Components: Documentation Versions: Python 3.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: chris.jerdonek, docs@python, eric.araujo, ezio.melotti, georg.brandl
Priority: normal Keywords:

Created on 2012-07-26 08:55 by chris.jerdonek, last changed 2013-10-08 18:42 by georg.brandl. This issue is now closed.

Messages (2)
msg166467 - (view) Author: Chris Jerdonek (chris.jerdonek) * (Python committer) Date: 2012-07-26 08:55
I haven't tracked down the reason for this, but certain index entries seem to be getting skipped in the Glossary.  If you view source on the Glossary page and search for "index-":

http://docs.python.org/dev/glossary.html

You will find that it skips from 'index-2' to 'index-5'.  Only :pep: index entries are getting included even though the Glossary's rst file contains explicit index directives (where 'index-3' and 'index-4' would otherwise be).

I tried some experiments, and this seems to occur even if the index directive text does not match the name of the Glossary term.
msg168400 - (view) Author: Chris Jerdonek (chris.jerdonek) * (Python committer) Date: 2012-08-16 19:17
I created a Sphinx issue for this here:

https://bitbucket.org/birkenfeld/sphinx/issue/997/index-targets-not-getting-created-in
History
Date User Action Args
2013-10-08 18:42:19georg.brandlsetstatus: open -> closed
resolution: not a bug
2012-08-16 19:17:26chris.jerdoneksetmessages: + msg168400
2012-07-26 10:30:25ezio.melottisetnosy: + georg.brandl, ezio.melotti, eric.araujo
2012-07-26 08:55:35chris.jerdonekcreate