classification
Title: Improve dynamic linking support on AIX
Type: enhancement Stage: test needed
Components: Build Versions: Python 3.2
process
Status: closed Resolution: duplicate
Dependencies: Superseder: AIX shared library fix
View: 941346
Assigned To: Nosy List: ajaksu2, goeran, pitrou, sable
Priority: low Keywords: patch

Created on 2006-08-18 11:03 by goeran, last changed 2010-09-24 12:21 by pitrou. This issue is now closed.

Files
File name Uploaded Description Edit
configure.in.patch goeran, 2006-08-18 11:03 Suggested patch to configure.in
Messages (7)
msg50942 - (view) Author: Göran Uddeborg (goeran) Date: 2006-08-18 11:03
Python 2.4.3 does not produce a shared python library
on AIX even with the --enable-shared flag.  The
addition of the LDLIBRARY and RUNSHARED variables in
the patch should fix this.

If I create my own version of the Python engine in a
shared library, that version is not able to load any
modules.  My understanding is that this is because the
import directives used when building the modules say
that symbols should come from ".", which means the main
program.  In the patch I replace that with "..", which
should look both in the main program and loaded shared
libraries.

Strictly speaking you could argue that these are two
different problems, and could motivate two separate
reports.  But since they are closely related, both
having to do with dynamic linking on AIX, I submit them
together.
msg84487 - (view) Author: Daniel Diniz (ajaksu2) (Python triager) Date: 2009-03-30 03:52
Göran: do you still need this?
msg84531 - (view) Author: Göran Uddeborg (goeran) Date: 2009-03-30 09:44
It is a bit unclear.

We are currently still using Python 2.4 with my patch for the active
releases of our products.  It is at this time not quite clear if we will
continue to support AIX in future releases.  If we do, we will also have
to upgrade to a newer Python version.  But right now I do not know if we
will.  Nor, if so, when we will do this upgrade.
msg84727 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2009-03-31 00:09
I suggest keeping the issue open since building on AIX with proper
extension module support can be tricky, and it's good to have an idea of
what a possible patch looks like.
(especially if snakebite finally gets an AIX machine)
msg84728 - (view) Author: Daniel Diniz (ajaksu2) (Python triager) Date: 2009-03-31 00:29
OK :)
msg115265 - (view) Author: Sébastien Sablé (sable) Date: 2010-08-31 13:44
I proposed a patch in issue 941346 that is different from this one but which should result in a shared python library on AIX as well.

regards
msg117275 - (view) Author: Sébastien Sablé (sable) Date: 2010-09-24 12:19
I think this issue can be closed as a duplicate of issue 941346.
History
Date User Action Args
2010-09-24 12:21:15pitrousetstatus: open -> closed
resolution: duplicate
superseder: AIX shared library fix
2010-09-24 12:19:28sablesetmessages: + msg117275
2010-08-31 13:44:12sablesetnosy: + sable
messages: + msg115265
2010-08-24 20:07:15BreamoreBoysetversions: + Python 3.2, - Python 3.1, Python 2.7
2009-03-31 00:29:12ajaksu2setstatus: pending -> open

messages: + msg84728
2009-03-31 00:09:48pitrousetnosy: + pitrou
messages: + msg84727
2009-03-30 09:44:17goeransetmessages: + msg84531
2009-03-30 03:52:22ajaksu2setstatus: open -> pending
priority: normal -> low
type: enhancement

versions: + Python 3.1, Python 2.7, - Python 2.4
nosy: + ajaksu2

messages: + msg84487
stage: test needed
2006-08-18 11:03:33goerancreate