classification
Title: bytes/str mismatch in distribute
Type: behavior Stage: resolved
Components: Distutils Versions: Python 3.2
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: eric.araujo Nosy List: eric.araujo, mark, ned.deily, tarek
Priority: normal Keywords:

Created on 2012-07-17 09:07 by mark, last changed 2012-07-17 10:41 by ned.deily. This issue is now closed.

Messages (2)
msg165693 - (view) Author: Mark Summerfield (mark) * Date: 2012-07-17 09:07
I tried installing CherryPy into my local Python 3.2 build. I don't know if this is a problem with CherryPy's setup.py or with distribute but suspect the latter since I've had similar problems before.

$ /home/mark/opt/python32/bin/python3 setup.py install
running install
running bdist_egg
running egg_info
writing CherryPy.egg-info/PKG-INFO
writing top-level names to CherryPy.egg-info/top_level.txt
writing dependency_links to CherryPy.egg-info/dependency_links.txt
reading manifest file 'CherryPy.egg-info/SOURCES.txt'
reading manifest template 'MANIFEST.in'
writing manifest file 'CherryPy.egg-info/SOURCES.txt'
installing library code to build/bdist.linux-x86_64/egg
running install_lib
running build_py
creating build
creating build/lib
creating build/lib/cherrypy
copying cherrypy/_cperror.py -> build/lib/cherrypy
...
byte-compiling build/bdist.linux-x86_64/egg/cherrypy/_cperror.py to _cperror.pyc
...
installing package data to build/bdist.linux-x86_64/egg
running install_data
copying cherrypy/cherryd -> build/bdist.linux-x86_64/egg/cherrypy
...
creating build/bdist.linux-x86_64/egg/EGG-INFO
installing scripts to build/bdist.linux-x86_64/egg/EGG-INFO/scripts
running install_scripts
running build_scripts
creating build/scripts-3.2
copying and adjusting cherrypy/cherryd -> build/scripts-3.2
changing mode of build/scripts-3.2/cherryd from 644 to 755
creating build/bdist.linux-x86_64/egg/EGG-INFO/scripts
copying build/scripts-3.2/cherryd -> build/bdist.linux-x86_64/egg/EGG-INFO/scripts
changing mode of build/bdist.linux-x86_64/egg/EGG-INFO/scripts/cherryd to 755
copying CherryPy.egg-info/PKG-INFO -> build/bdist.linux-x86_64/egg/EGG-INFO
copying CherryPy.egg-info/SOURCES.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying CherryPy.egg-info/dependency_links.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
copying CherryPy.egg-info/top_level.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
zip_safe flag not set; analyzing archive contents...
cherrypy._cpmodpy: module references __file__
...
creating dist
creating 'dist/CherryPy-3.2.2-py3.2.egg' and adding 'build/bdist.linux-x86_64/egg' to it
removing 'build/bdist.linux-x86_64/egg' (and everything under it)
Processing CherryPy-3.2.2-py3.2.egg
creating /home/mark/opt/python32/lib/python3.2/site-packages/CherryPy-3.2.2-py3.2.egg
Extracting CherryPy-3.2.2-py3.2.egg to /home/mark/opt/python32/lib/python3.2/site-packages
Adding CherryPy 3.2.2 to easy-install.pth file
Traceback (most recent call last):
  File "setup.py", line 144, in <module>
    main()
  File "setup.py", line 139, in main
    cmdclass=cmd_class,
  File "/home/mark/opt/python32/lib/python3.2/distutils/core.py", line 148, in setup
    dist.run_commands()
  File "/home/mark/opt/python32/lib/python3.2/distutils/dist.py", line 917, in run_commands
    self.run_command(cmd)
  File "/home/mark/opt/python32/lib/python3.2/distutils/dist.py", line 936, in run_command
    cmd_obj.run()
  File "/home/mark/opt/python32/lib/python3.2/site-packages/distribute-0.6.10-py3.2.egg/setuptools/command/install.py", line 73, in run
    self.do_egg_install()
  File "/home/mark/opt/python32/lib/python3.2/site-packages/distribute-0.6.10-py3.2.egg/setuptools/command/install.py", line 101, in do_egg_install
    cmd.run()
  File "/home/mark/opt/python32/lib/python3.2/site-packages/distribute-0.6.10-py3.2.egg/setuptools/command/easy_install.py", line 236, in run
    self.easy_install(spec, not self.no_deps)
  File "/home/mark/opt/python32/lib/python3.2/site-packages/distribute-0.6.10-py3.2.egg/setuptools/command/easy_install.py", line 452, in easy_install
    return self.install_item(None, spec, tmpdir, deps, True)
  File "/home/mark/opt/python32/lib/python3.2/site-packages/distribute-0.6.10-py3.2.egg/setuptools/command/easy_install.py", line 503, in install_item
    self.process_distribution(spec, dist, deps)
  File "/home/mark/opt/python32/lib/python3.2/site-packages/distribute-0.6.10-py3.2.egg/setuptools/command/easy_install.py", line 522, in process_distribution
    self.install_egg_scripts(dist)
  File "/home/mark/opt/python32/lib/python3.2/site-packages/distribute-0.6.10-py3.2.egg/setuptools/command/easy_install.py", line 401, in install_egg_scripts
    dist.get_metadata('scripts/'+script_name)
  File "/home/mark/opt/python32/lib/python3.2/site-packages/distribute-0.6.10-py3.2.egg/setuptools/command/easy_install.py", line 615, in install_script
    script_text = get_script_header(script_text) + (
  File "/home/mark/opt/python32/lib/python3.2/site-packages/distribute-0.6.10-py3.2.egg/setuptools/command/easy_install.py", line 1449, in get_script_header
    match = first_line_re.match(first)
TypeError: can't use a bytes pattern on a string-like object
msg165700 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2012-07-17 10:40
Distribute is not part of Distutils. According to its PyPI page (http://pypi.python.org/pypi/distribute#feedback-and-getting-involved), the project has its own issue tracker at https://bitbucket.org/tarek/distribute/issues/
History
Date User Action Args
2012-07-17 10:41:24ned.deilysetstage: resolved
2012-07-17 10:40:54ned.deilysetstatus: open -> closed

nosy: + ned.deily
messages: + msg165700

resolution: not a bug
2012-07-17 09:07:03markcreate