classification
Title: test_runpy should include namespace package tests
Type: enhancement Stage: resolved
Components: Tests Versions: Python 3.3
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: ncoghlan Nosy List: adam-collard, akuchling, chrish42, ncoghlan
Priority: normal Keywords:

Created on 2012-07-16 14:26 by ncoghlan, last changed 2014-04-15 15:41 by akuchling. This issue is now closed.

Messages (3)
msg165613 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2012-07-16 14:26
test_runpy doesn't currently check that code can be correctly executed from namespace packages
msg216137 - (view) Author: Christian Hudon (chrish42) * Date: 2014-04-14 17:57
As far as I can see, this is now tested by the following tests in test_runpy:

test_run_module_in_namespace_package
test_run_package_in_namespace_package
test_run_namespace_package
test_run_namespace_package_in_namespace_package

(These new tests were in introduced in revision 87961, on Dec 15th, 2013.)

Can someone who knows more about CPython's implementation confirm that these tests do cover what was intended with this bug report (and then close the bug), or if not, flesh out the bug report with what's missing, and I'll do my best to add the missing tests.
msg216312 - (view) Author: A.M. Kuchling (akuchling) * (Python committer) Date: 2014-04-15 15:41
Because Nick both originally created this ticket and also added the new tests (http://hg.python.org/cpython/rev/51dddfead80a/), I'll assume he knew what he was doing when he named those methods, and simply forgot to close this issue.
History
Date User Action Args
2014-04-15 15:41:37akuchlingsetstatus: open -> closed

assignee: ncoghlan

nosy: + akuchling
messages: + msg216312
resolution: fixed
stage: resolved
2014-04-14 17:57:04chrish42setnosy: + chrish42
messages: + msg216137
2013-07-06 13:05:48adam-collardsetnosy: + adam-collard
2012-07-16 14:26:11ncoghlancreate