classification
Title: datetime instances lack __module__ attribute
Type: behavior Stage:
Components: Library (Lib) Versions: Python 3.3, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Arfrever, amaury.forgeotdarc, chris.jerdonek, eric.snow, r.david.murray
Priority: normal Keywords:

Created on 2012-06-29 16:05 by chris.jerdonek, last changed 2013-06-24 03:27 by belopolsky. This issue is now closed.

Messages (6)
msg164332 - (view) Author: Chris Jerdonek (chris.jerdonek) * (Python committer) Date: 2012-06-29 16:05
Instances of datetime.datetime don't seem to have the '__module__' attribute even though the datetime class itself does.

This seems to contradict Section 3.2 of the Python documentation about the standard type hierarchy (in the subsection called "Class instances"): http://docs.python.org/dev/reference/datamodel.html#the-standard-type-hierarchy

"A class instance has a namespace implemented as a dictionary which is the first place in which attribute references are searched. When an attribute is not found there, and the instance’s class has an attribute by that name, the search continues with the class attributes."

Instances of other classes defined in the standard library do have the attribute.

The session below illustrates the issue:

Python 3.3.0a4 (v3.3.0a4:7c51388a3aa7, May 30 2012, 16:58:42) 
[GCC 4.2.1 (Apple Inc. build 5666) (dot 3)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> from datetime import datetime
>>> datetime.__module__
'datetime'
>>> d = datetime(2000, 1, 1)
>>> d.__class__ 
<class 'datetime.datetime'>
>>> d.__module__
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
AttributeError: 'datetime.datetime' object has no attribute '__module__'
msg164340 - (view) Author: Chris Jerdonek (chris.jerdonek) * (Python committer) Date: 2012-06-29 17:54
Also, FWIW, in PyPy the behavior is different.  Datetime instances do have the __module__ attribute:

Python 2.7.2 (341e1e3821fff77db3bb5cdb7a4851626298c44e, Jun 09 2012, 14:24:11)
[PyPy 1.9.0] on darwin
Type "help", "copyright", "credits" or "license" for more information.
And now for something completely different: ``pypy is the nuclear fusion of
programming language implementation (pedronis)''
>>>> from datetime import datetime
>>>> datetime.__module__
'datetime'
>>>> d = datetime(2000, 1, 1)
>>>> d.__module__
'datetime'
msg164364 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2012-06-30 01:36
This is true for most (all?) CPython classes that are implemented in C.  For example io.StringIO instances do not have a __module__ attribute either.
msg164365 - (view) Author: Chris Jerdonek (chris.jerdonek) * (Python committer) Date: 2012-06-30 01:43
Thanks.  I suspected that might be the case.  Then the question becomes whether failing to fall back to the class attribute is the desired behavior, and if not, to update the documentation accordingly.
msg164366 - (view) Author: Chris Jerdonek (chris.jerdonek) * (Python committer) Date: 2012-06-30 04:09
datetime.__dict__ is another attribute that behaves this way (i.e. doesn't exist for instances in CPython but does for PyPy).
msg164513 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2012-07-02 12:33
In PyPy, datetime.py is a pure Python module (similar to the one in 3.x, but without the _datetime acceleration module).  So comparison with CPython is not relevant here.

In CPython, __module__ is not an attribute of the type, but a property: it is defined in the 'type' object.  The situation is similar to the following script (2.x syntax); the "foo" attribute can be found on the class, but not on instances of the class.

class Type(type):
    foo = 42
class Datetime:
    __metaclass__ = Type
print Datetime.foo
print Datetime().foo

This is a good thing sometimes: for example 'str' has a __dict__ (containing methods) but strings don't have a __dict__ -- storage is optimized and only has an array of chars.  In this case you wouldn't want the class __dict__ be returned instead.
History
Date User Action Args
2013-06-24 03:27:22belopolskysetstatus: open -> closed
resolution: not a bug
2012-11-13 04:29:12eric.snowsetnosy: + eric.snow
2012-07-02 12:33:33amaury.forgeotdarcsetnosy: + amaury.forgeotdarc
messages: + msg164513
2012-06-30 04:09:56chris.jerdoneksetmessages: + msg164366
2012-06-30 03:46:29Arfreversetnosy: + Arfrever
2012-06-30 01:43:43chris.jerdoneksetmessages: + msg164365
2012-06-30 01:36:31r.david.murraysetnosy: + r.david.murray
messages: + msg164364
2012-06-29 17:55:46chris.jerdoneksetversions: + Python 3.3
2012-06-29 17:54:33chris.jerdoneksetversions: + Python 2.7, - Python 3.3
2012-06-29 17:54:09chris.jerdoneksetmessages: + msg164340
2012-06-29 16:05:27chris.jerdonekcreate