classification
Title: Fix 64-bit building for buildbot scripts (3.2)
Type: crash Stage: commit review
Components: Build Versions: Python 3.2
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: brian.curtin, db3l, jeremy.kloth, jkloth, loewis, pitrou, python-dev, skrah, zach.ware
Priority: normal Keywords:

Created on 2012-06-24 20:30 by skrah, last changed 2012-07-18 09:36 by skrah. This issue is now closed.

Messages (9)
msg163848 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2012-06-24 20:30
[from #15102]
http://buildbot.python.org/all/builders/AMD64%20Windows7%20SP1%203.2
msg163963 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2012-06-25 13:04
New changeset 334ff92a8483 by Stefan Krah in branch '3.2':
Issue #15171: Try the HOST_PYTHON hack for 3.2.
http://hg.python.org/cpython/rev/334ff92a8483
msg163971 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2012-06-25 14:02
The buildbot works with the HOST_PYTHON hack. Should we just leave
this as a permanent solution? -- I don't feel like touching the project
files for stable releases.

[%CD% should probably be quoted in the patch.]
msg164400 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2012-06-30 16:43
New changeset 177f93f0f5b9 by Stefan Krah in branch '3.2':
Issue #15171: Quote the variable that expands to the current directory.
http://hg.python.org/cpython/rev/177f93f0f5b9
msg164418 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2012-06-30 19:26
Did the Windows XP-4 bot start failing after 334ff92a8483 ?

The logs don't go back very far:

http://buildbot.python.org/all/builders/x86%20XP-4%203.2
msg165584 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2012-07-16 10:23
David, do you have an idea why the XP-4 3.2 machine fails the compile?
I can't reproduce this and I don't know if it's related to
334ff92a8483 or 177f93f0f5b9.
msg165649 - (view) Author: David Bolen (db3l) * Date: 2012-07-16 19:26
It seems really unlikely to be related to this issue since I'm pretty sure build-amd64 doesn't get used on XP-4.

From the log it looks like it couldn't clean out and reuse the VS temporary build directory.  Manually cleaning it out and restarting the last build appears to have at least gotten past compiling.

I can't really explain why this was a problem, when I was able to manually remove the directory without error, and couldn't find any stray processes that may have been holding references to the files in that temporary directory.
msg165653 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2012-07-16 20:19
David, since you are here, perhaps you could take a look at why your Windows 7 buildbot doesn't compile?
http://buildbot.python.org/all/builders/x86%20Windows7%203.x

I tried to e-mail you but apparently you didn't receive the message.
msg165749 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2012-07-18 09:36
Thanks, David! I'll close this issue, perhaps the compile failures
on the Windows 7 buildbot can be sorted out separately.
History
Date User Action Args
2012-07-18 09:36:20skrahsetstatus: open -> closed

messages: + msg165749
2012-07-16 20:19:06pitrousetmessages: + msg165653
2012-07-16 19:26:58db3lsetmessages: + msg165649
2012-07-16 10:23:32skrahsetnosy: + db3l
messages: + msg165584
2012-06-30 19:26:42skrahsetmessages: + msg164418
2012-06-30 16:43:35python-devsetmessages: + msg164400
2012-06-25 14:02:44skrahsetversions: + Python 3.2
resolution: fixed
messages: + msg163971

components: + Build
type: crash
stage: commit review
2012-06-25 13:04:36python-devsetnosy: + python-dev
messages: + msg163963
2012-06-24 20:30:08skrahcreate