classification
Title: Use dynload_shlib on newer HP-UX versions
Type: enhancement Stage: resolved
Components: Interpreter Core Versions: Python 2.7
process
Status: closed Resolution: rejected
Dependencies: 1454844 Superseder:
Assigned To: Nosy List: Oren_Held, ajaksu2, kjetilja
Priority: low Keywords:

Created on 2006-07-04 10:42 by kjetilja, last changed 2011-05-04 19:50 by Oren_Held. This issue is now closed.

Messages (3)
msg60938 - (view) Author: Kjetil Jacobsen (kjetilja) Date: 2006-07-04 10:42
I'm working on a Python application which uses lots of
extension modules (typically 100-200).  This has worked
fine until recently when we added a few more extension
modules to the application, where some of the (c++)
extensions  link with a common shared (c++) library. 
Now, suddenly things start crashing because global
symbol sharing in the extension modules and the library
shared among the extension gets mixed up.

The problem has been confirmed to appear on both
PA-RISC and Itanium versions of "recent" (>= version 11
of HP-UX).  I assume older versions of HP-UX should use
dynload_hpux.c as before.

The problem disappears when using dynload_shlib.c
instead of dynload_hpux.c when building Python for HP-UX.

This bug seems related to the issue reported in
http://sourceforge.net/tracker/index.php?func=detail&aid=1454844&group_id=5470&atid=305470
msg84510 - (view) Author: Daniel Diniz (ajaksu2) (Python triager) Date: 2009-03-30 05:19
Kjetil, has issue 1454844 fixed this?
msg135153 - (view) Author: Oren Held (Oren_Held) Date: 2011-05-04 19:50
ajaksu2: the ticket you referred to fixed it for Darwin only, afaik. HP-UX, regardless of versions, still use the old dynload_hpux.c.
History
Date User Action Args
2011-05-04 19:50:41Oren_Heldsetnosy: + Oren_Held
messages: + msg135153
2009-04-25 21:39:47ajaksu2setstatus: pending -> closed
resolution: rejected
stage: test needed -> resolved
2009-03-30 05:19:00ajaksu2setstatus: open -> pending
priority: normal -> low
type: enhancement
dependencies: + Use dlopen() to load extensions on Darwin, where possible

versions: + Python 2.7, - Python 2.5
nosy: + ajaksu2

messages: + msg84510
stage: test needed
2006-07-04 10:42:07kjetiljacreate