classification
Title: HOWTOs doesn't link to "Idioms and Anti-Idioms" article
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 3.2
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, ezio.melotti, fossilet, terry.reedy
Priority: normal Keywords:

Created on 2012-06-22 11:13 by fossilet, last changed 2012-06-23 12:46 by ezio.melotti. This issue is now closed.

Messages (3)
msg163396 - (view) Author: Yongzhi Pan (fossilet) * Date: 2012-06-22 11:13
In the py3k docs howtos table of contents, http://docs.python.org/py3k/howto/index.html, the link to the article "Idioms and Anti-Idioms in Python" is gone, but the article is still in the doc. It is at http://docs.python.org/py3k/howto/doanddont.html. Should it have a link at the howtos section?
msg163544 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2012-06-23 07:40
The file is 'controversial'. The link was intentionally removed (and the file deleted and restored but not relinked, pending update) in #7391 (which was closed and re-opened).

Your links do not work because the comma/period that follow are considered part of the urls. To be safe, always follow with whitespace.
msg163598 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2012-06-23 12:46
> Your links do not work because the comma/period that follow are 
> considered part of the urls. To be safe, always follow with whitespace.

FWIW this will be fixed soon and the fix will work on older messages too:
http://psf.upfronthosting.co.za/roundup/meta/issue437
http://issues.roundup-tracker.org/issue2550759
History
Date User Action Args
2012-06-23 12:46:16ezio.melottisetmessages: + msg163598
2012-06-23 07:40:46terry.reedysetstatus: open -> closed

nosy: + terry.reedy
messages: + msg163544

resolution: not a bug
stage: resolved
2012-06-22 11:18:09ezio.melottisetnosy: + ezio.melotti
2012-06-22 11:13:11fossiletcreate