classification
Title: Add gzip support to urllib.request.retrieve()
Type: enhancement Stage:
Components: Library (Lib) Versions: Python 3.4
process
Status: closed Resolution: duplicate
Dependencies: Superseder: transparent gzip compression in urllib
View: 1508475
Assigned To: Nosy List: jcea, rhettinger, serhiy.storchaka
Priority: normal Keywords: easy

Created on 2012-06-17 06:51 by rhettinger, last changed 2012-06-17 14:29 by jcea. This issue is now closed.

Messages (2)
msg163020 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2012-06-17 06:51
Enable retrieve() to take advantage of data compression in HTTP requests.

* In the request, add the header "Accept-Encoding: gzip".
* In the response, check the headers for "Content-Encoding: gzip".
* Convert the downloaded content using gzip.GzipFile.
msg163027 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2012-06-17 08:17
Isn't this a duplicate of issue1508475?
History
Date User Action Args
2012-06-17 14:29:38jceasetnosy: + jcea
2012-06-17 10:32:19pitrousetstatus: open -> closed
superseder: transparent gzip compression in urllib
resolution: duplicate
2012-06-17 08:17:58serhiy.storchakasetnosy: + serhiy.storchaka
messages: + msg163027
2012-06-17 06:51:12rhettingercreate