This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

classification
Title: OSX: ranlib: file: libpython2.7.a(pymath.o) has no symbols
Type: compile error Stage:
Components: macOS Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: ronaldoussoren Nosy List: ronaldoussoren, samueljohn
Priority: normal Keywords:

Created on 2012-06-01 15:40 by samueljohn, last changed 2022-04-11 14:57 by admin. This issue is now closed.

Messages (2)
msg162078 - (view) Author: Samuel John (samueljohn) Date: 2012-06-01 15:40
Building python on the Mac (10.7.4) with latest Xcode shows

```
[...]
ranlib: file: libpython2.7.a(pymath.o) has no symbols
```

Is that okay or a bug?
msg162079 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2012-06-01 15:46
That's not a bug, the build prices unconditionally builds a file that contains optional definitions. On OSX none of these optional definitions are used, and hence pymath.o is empty.
History
Date User Action Args
2022-04-11 14:57:31adminsetgithub: 59185
2012-06-01 15:46:16ronaldoussorensetstatus: open -> closed
resolution: not a bug
messages: + msg162079
2012-06-01 15:42:37samueljohnsettitle: ranlib: file: libpython2.7.a(pymath.o) has no symbols -> OSX: ranlib: file: libpython2.7.a(pymath.o) has no symbols
2012-06-01 15:40:55samueljohncreate