classification
Title: rename packaging.pypi to packaging.index
Type: enhancement Stage: resolved
Components: Distutils2 Versions: Python 3.4, 3rd party
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: alexis Nosy List: alexis, eric.araujo, tarek, westley.martinez
Priority: normal Keywords:

Created on 2012-05-31 22:14 by alexis, last changed 2013-08-30 14:17 by eric.araujo. This issue is now closed.

Messages (9)
msg162027 - (view) Author: Alexis Metaireau (alexis) * (Python triager) Date: 2012-05-31 22:14
PyPI is the name of a particular index, whereas "index" is a generic term.

So ISTM that it would be better to use the latter, semantically-wise.
msg162029 - (view) Author: Hynek Schlawack (hynek) * (Python committer) Date: 2012-05-31 22:26
While I can see your point, I think that "index" is way too generic. I also think that the pypi term is overloaded with both meanings.
msg162045 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2012-06-01 03:01
We could use “catalog” (see how the interest group for PyPI is named catalog-sig), but it sounds a bit abstract to me, and at the same time fails to convey that this module deals with finding things (in an index/catalog) and also download them (from PyPI or third-party sites).  Anyway I don’t think names can be perfect; just like distutils2.database may be ambiguous if one doesn’t know that it works with the database of installed projects, distutils2.index can be ambiguous if one doesn’t know that the repository of information (and sometimes downloads) is called an index.

+1 for distutils2.index
+0.3 for distutils2.repository (long, and mostly used with VCS these days)
±0 for distutils2.pypi
msg162057 - (view) Author: Alexis Metaireau (alexis) * (Python triager) Date: 2012-06-01 08:28
We are all calling these indexes quite everywhere. We are talking about 
a Python Package Index and even the mirroring infrastructure is talking 
about indexes. Because that's under the "packaging" namespace, it's 
kind of obvious that this deals with indexes "like PyPI".

Of course, we also have the documentation which is a good starting 
point to make people realize what this is about; but I really don't 
think naming this "index" will be a blocker for anyone.
msg162166 - (view) Author: Westley Martínez (westley.martinez) * Date: 2012-06-02 19:05
-1
index is too generic to convey any kind of meaning and can be confused--atleast for me--with list.index. Sometimes it is better for a name to be specific.
msg162345 - (view) Author: Alexis Metaireau (alexis) * (Python triager) Date: 2012-06-05 14:03
The problem is that PyPI isn't a good name since it's the name of ONE 
index.

Westley, do you have any other idea?

Otherwise, I think we should stick to "index", which is a good name for 
something that's named "index" quite everywhere already. Especially 
because it's living under the "packaging" namespace.
msg163899 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2012-06-25 06:05
Fully agreed with Alexis.

> index is too generic to convey any kind of meaning and can be confused--at least for
> me--with list.index. Sometimes it is better for a name to be specific.
But it is specific, thanks to the use of namespaces in Python: it’s distutils2.index/packaging.index.  Also take into account that this a module name that will be seen by people writing packaging tools (and thus familiar with “the Python Packages Index”), not end-users which may be Python developers.

Hynek: I don’t understand “I also think that the pypi term is overloaded with both meanings”.
msg196519 - (view) Author: Westley Martínez (westley.martinez) * Date: 2013-08-30 07:07
I think I like the term catalog myself, but I'm not wholly opposed to index.  I think it is certainly better than pypi.

Although the namespace does reduce the genericness of index, a lot of programmers (including me) like to use the from namespace import x method.  I think that's considerable.  That said, programmers could use from packaging import index as pindex or some sort to alleviate this.
msg196545 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2013-08-30 14:17
The issue is moot now that packaging/distutils2 is stopped.
History
Date User Action Args
2013-08-30 14:17:03eric.araujosetstatus: open -> closed
resolution: out of date
messages: + msg196545

stage: needs patch -> resolved
2013-08-30 07:07:00westley.martinezsetmessages: + msg196519
2012-06-25 06:05:28eric.araujosetversions: - Python 3.3
2012-06-25 06:05:17eric.araujosetmessages: + msg163899
versions: + Python 3.4
2012-06-24 07:33:27hyneksetnosy: - hynek
2012-06-05 14:03:43alexissetmessages: + msg162345
2012-06-02 19:05:50westley.martinezsetnosy: + westley.martinez
messages: + msg162166
2012-06-01 08:28:52alexissetmessages: + msg162057
2012-06-01 03:01:18eric.araujosetnosy: + eric.araujo

messages: + msg162045
versions: + 3rd party
2012-05-31 22:26:14hyneksetnosy: + hynek
messages: + msg162029
2012-05-31 22:14:21alexiscreate