classification
Title: test_unicode_repr_oflw (in test_bigmem) crashes
Type: crash Stage: resolved
Components: Interpreter Core, Tests Versions: Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: serhiy.storchaka Nosy List: BreamoreBoy, benjamin.peterson, lukasz.langa, pitrou, python-dev, serhiy.storchaka, twouters, vstinner
Priority: normal Keywords: patch

Created on 2012-05-24 23:46 by pitrou, last changed 2015-03-30 07:07 by serhiy.storchaka. This issue is now closed.

Files
File name Uploaded Description Edit
issue14904.patch serhiy.storchaka, 2015-03-14 12:14 review
Messages (6)
msg161535 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2012-05-24 23:46
Someone needs to debug this (someone with enough RAM).

http://www.python.org/dev/buildbot/all/builders/AMD64%20Ubuntu%20LTS%20bigmem%202.7/builds/6/steps/test/logs/stdio

My intuition is that the crash is on the eval(), since test_unicode_repr above passes.
msg162304 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2012-06-04 23:08
> Someone needs to debug this (someone with enough RAM).

I tried to reproduce the bug, but I got a bug in my filesystem :-p A memory allocation failed in the kernel and btrfs didn't handle it correctly. 12 GB of RAM (and no swap) is maybe not enough.
msg162918 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2012-06-15 16:36
New changeset 1c9635109079 by Antoine Pitrou in branch '2.7':
Skip test_bigmem.test_unicode_repr_oflw, since it crashes (issue #14904).
http://hg.python.org/cpython/rev/1c9635109079
msg221869 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-06-29 18:02
Has anybody got a machine with enough RAM to be able to debug this now as I certainly haven't?
msg238080 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2015-03-14 12:14
Unfortunately original logs are not available.

test_unicode_repr_oflw incorrectly declares required memory usage. It declares only 6.4 GiB, but actually needs 10.4 GiB only on narrow build (and at least 13.4 on wide build).

Proposed patch fixes memuse parameters in test_unicode_repr_oflw and other bigmem tests. It also changes test_unicode_repr_oflw so it no more uses eval(), is much faster, and requires only 5.33 GiB on narrow build (6.67 GiB on wide build) (based on Python 3 tests).

Please test.
msg239571 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2015-03-30 06:28
New changeset 5bea08f80e62 by Serhiy Storchaka in branch '2.7':
Issue #14904: Made test_unicode_repr_oflw to use less memory.
https://hg.python.org/cpython/rev/5bea08f80e62
History
Date User Action Args
2015-03-30 07:07:28serhiy.storchakasetstatus: open -> closed
resolution: fixed
stage: patch review -> resolved
2015-03-30 06:28:10python-devsetmessages: + msg239571
2015-03-24 20:07:01serhiy.storchakasetassignee: serhiy.storchaka
2015-03-14 12:14:55serhiy.storchakasetfiles: + issue14904.patch

nosy: + serhiy.storchaka
messages: + msg238080

keywords: + patch
stage: patch review
2014-06-29 18:02:24BreamoreBoysetnosy: + BreamoreBoy
messages: + msg221869
2012-06-15 16:36:56python-devsetnosy: + python-dev
messages: + msg162918
2012-06-04 23:08:33vstinnersetmessages: + msg162304
2012-05-30 20:57:45vstinnersetnosy: + vstinner
2012-05-24 23:46:52pitroucreate