classification
Title: PC new-logo-based icon set
Type: Stage:
Components: Windows Versions: Python 2.5
process
Status: closed Resolution: accepted
Dependencies: Superseder:
Assigned To: loewis Nosy List: bobince, loewis
Priority: release blocker Keywords: patch

Created on 2006-05-17 16:59 by bobince, last changed 2006-06-03 07:42 by loewis. This issue is now closed.

Files
File name Uploaded Description Edit
win32-icons.zip bobince, 2006-05-17 16:59 PC/win32 icon set
win32-icons2.zip bobince, 2006-06-03 07:29 Icon set - revised
Messages (11)
msg50272 - (view) Author: Andrew Clover (bobince) * Date: 2006-05-17 16:59
Following positive discussion on -dev, here's the
updated version of the PC/py*.ico files I hacked up a
while ago.

The attachment is a ZIP, not a patch, as it contains
only binaries. Also available as tgz:

  http://doxdesk.com/img/software/py/win32-icons.tar.gz

Also possibly of interest:

  http://doxdesk.com/img/software/py/icons3.zip

This attachment contains only the simple replacement
files; the icons3 ZIP also contains:

  - source
  - versions including Windows Vista large icons
    (probably not worth including at this point as they're
    quite sizable and no-one is using Vista yet)
  - an egg icon
    (there is currently no installer/shell support for
eggs,
    but could be worth adding in future)
  - a new installer side banner
    (this has not currently seen any discussion on -dev,
    but may be worth considering if the intention is to
    leave behind the purple/green snake branding)
msg50273 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2006-05-19 11:22
Logged In: YES 
user_id=21627

Thanks! Are you willing to contribute them to the PSF, under
the terms of the contributor agreement at

http://www.python.org/psf/contrib/contrib-form/

?
msg50274 - (view) Author: Andrew Clover (bobince) * Date: 2006-05-19 14:21
Logged In: YES 
user_id=311085

Sure, no worries. I'll fax over the -python version since I
have ancient contributions to cover too.
msg50275 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2006-05-22 08:56
Logged In: YES 
user_id=21627

Thanks for the patch. I have committed it as r46063. I put a
demo installer containing them at

http://www.dcl.hpi.uni-potsdam.de/home/loewis/python-2.5.13290.msi

I would also like to add the source files, but I have
difficulties figuring out what they are. There is a source
directory; with:

- baselogo.svg; I assume this is a source file
- icons.svgz; can't figure out what this is
- source.xar; not sure either
- a directory called png, with many png file - I expect
  that these aren't source files, are they?
msg50276 - (view) Author: Andrew Clover (bobince) * Date: 2006-05-26 02:50
Logged In: YES 
user_id=311085

> I put a demo installer containing them

Seems to work OK. The thanks at the end still attributes the
graphic to Erik though; I'm not after an ack there myself,
but changing the text to not imply the current graphic is
his one may be appropriate.

> baselogo.svg; I assume this is a source file

Yes. This is just the Python logo itself (the gradient
version as used on the new website), in vector format.

> icons.svgz; can't figure out what this is

Same as source.xar, but exported as W3C standard SVG format
for wider compatibility [compressed, hence the 'z'].

Unfortunately because SVG cannot reproduce some of effects
used, and because the SVG export path is currently quite
bad, it's not really directly usable, but it might be of use
to anyone who wants to hack on the graphics but doesn't use
Xara.

> source.xar; not sure either

This is the primary vector graphics source of the icons -
the other SVG and PNG files are just there because other
people requested them.

It's in Xara format, a previously proprietary graphics
application which has now gone open-source and is heading
rapidly towards being usable on Linux, but isn't quite there
yet.

> a directory called png, with many png file - I expect
> that these aren't source files, are they?

Nope, they're just exactly the same content as in the
(with-vista) .ico files, just supplied as PNG for anyone who
wants to fiddle with them in a more accessible bitmap format.
msg50277 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2006-05-26 17:02
Logged In: YES 
user_id=21627

Ok, I will then do the following changes still:
- add baselogo.svg and source.xar (ignore all the other files),
- remove the attribution for Erik (sorry for missing that)
msg50278 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2006-05-28 16:58
Logged In: YES 
user_id=21627

Committed the rest as r46503. Thanks again!
msg50279 - (view) Author: Andrew Clover (bobince) * Date: 2006-05-30 16:20
Logged In: YES 
user_id=311085

No probs and ta!

However...

I've got more altered icons, attached and at
http://doxdesk.com/img/software/py/win32-icons2.zip . Sorry
for the inconvenience - pretty sure these are 'final'.

The problem with the old files? Well it seems there's a bug
in Windows that can cause redraw errors on 32-bit
alpha-blended XP icons. I can't find any doc on this at all,
but from experiment it seems that it can occur when icons
are partially redrawn instead of drawn all at once. This is
most easily provoked by slowly dragging a window on top of
an Explorer window in Tiles/Icons/List mode, to reveal the
icon underneath.

It looks to be an arithmetic overflow in compositing: when a
nearly-transparent white pixel being plotted onto pure white
background in this partial-redraw code, a black pixel can
unexpectedly result, with poor-looking results. (Thanks,
Windows.)

I've hacked the bitmaps to avoid places where they're
white-and-transparent enough to be able to provoke this
aggravating occasional behaviour. Also while I'm at it, I've
removed the 256 colour 48x48 icons, since it saves a few K
and there's almost no practical case where they're of benefit.

cheers,
msg50280 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2006-06-03 07:01
Logged In: YES 
user_id=21627

Hmm, I'm getting an http error 404 when accessing
http://doxdesk.com/img/software/py/win32-icons2.zip
msg50281 - (view) Author: Andrew Clover (bobince) * Date: 2006-06-03 07:29
Logged In: YES 
user_id=311085

Oh! Sorry - it's there now, and attached, as I had meant to
do originally.

No changes to any of the source files, as it's purely a
.ICO-level fix.

Cheers,
msg50282 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2006-06-03 07:42
Logged In: YES 
user_id=21627

Thanks, committed as 46610.
History
Date User Action Args
2006-05-17 16:59:50bobincecreate