classification
Title: 2.4.3 fails to find Tcl/Tk on Solaris 10 x86_64
Type: behavior Stage: test needed
Components: Build Versions: Python 2.6
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: BreamoreBoy, ajaksu2, enchanter, loewis
Priority: low Keywords:

Created on 2006-05-16 01:52 by enchanter, last changed 2010-08-22 10:18 by BreamoreBoy. This issue is now closed.

Messages (4)
msg60912 - (view) Author: Tim Mooney (enchanter) Date: 2006-05-16 01:52
First, I'm a complete python newbie, but I have lots of
experience with other languages and I'm very
experienced at building software on UNIX platforms.

I've built 64 bit (LP64) versions of Tcl 8.4.13 and Tk
8.4.13 with the Sun Studio 11 compiler.  They're
installed under /local, with the libraries in
/local/lib/64 , since the Solaris convention is to use
lib/64 for ELF64 libraries.

I can configure and compile Python 2.4.3 as an LP64
executable, but setup.py fails to find Tcl/Tk.  I'm
suspicious (but not certain) that the problem is that
the calls to self.compiler.find_library_file in
setup.py aren't finding any of the locally installed
libraries because find_library_file isn't searching the
"64" subdirectory under lib.

I've been through the README, and looked at the URL for
the FAQ mentioned in the README (though I don't see a
"section 3" of the FAQ).  Most of the suggestions in
the README in the Solaris section are geared toward
what to do when python can't find your shared libraries
*at run time*.  That's not the problem here.  I have my
loader set up (via crle with the -64 option) to search
all of the necessary locally-installed directories that
contain ELF64 libraries.  The problem is that Python's
setup can't find the libraries in the first place.

Suggestions?  If I already knew Python, I could
probably figure out how to subclass "compiler" to
always search the "/64" version of a library directory
when I'm on Solaris and the compiler flags contain a
certain set of characters (better yet would be to
actually compile something to an object file and test
whether it's ELF64).  Unfortunately, I'm not at that
level yet.

This instance is specific to Solaris, but the general
problem applies to other multi-ABI platforms too, like
IRIX, HP-UX, etc.
msg60913 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2006-05-19 11:48
Logged In: YES 
user_id=21627

The easiest work-around should be to edit Modules/Setup,
enabling the entire _tkinter block, with all libraries and
paths needed.
msg83914 - (view) Author: Daniel Diniz (ajaksu2) (Python triager) Date: 2009-03-21 02:45
Looks like a works for me.
msg114661 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2010-08-22 10:18
Closed in reply to msg83914.
History
Date User Action Args
2010-08-22 10:18:44BreamoreBoysetstatus: open -> closed

nosy: + BreamoreBoy
messages: + msg114661

resolution: works for me
2009-03-21 02:45:54ajaksu2setpriority: normal -> low

type: behavior

title: 2.4.3 fails to find Tcl/Tk on Solaris 10 x86_64 -> 2.4.3 fails to find Tcl/Tk on Solaris 10 x86_64
nosy: + ajaksu2
versions: + Python 2.6, - Python 2.4
messages: + msg83914
stage: test needed
2006-05-16 01:52:18enchantercreate