classification
Title: html documentation does not show comments in code blocks
Type: behavior Stage: resolved
Components: Documentation Versions: Python 3.2, Python 3.3, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: doctest directive examples in library/doctest.html lack the flags
View: 12947
Assigned To: docs@python Nosy List: alexgarel, docs@python, ezio.melotti
Priority: normal Keywords:

Created on 2012-05-22 14:15 by alexgarel, last changed 2012-05-22 14:18 by ezio.melotti. This issue is now closed.

Messages (2)
msg161351 - (view) Author: Alex Garel (alexgarel) Date: 2012-05-22 14:15
Just under http://docs.python.org/library/doctest.html#doctest.REPORTING_FLAGS documentation speaks about how Doctest directives maybe expressed as special Python comments.

There are some example along with the narrative story, however comments which here are the important part, are not displayed in code snippet.

Looking at the sphinx source for this page : http://docs.python.org/_sources/library/doctest.txt the comments are present. Eg.

   >>> print range(20) #doctest: +NORMALIZE_WHITESPACE
   [0,   1,  2,  3,  4,  5,  6,  7,  8,  9,
   10,  11, 12, 13, 14, 15, 16, 17, 18, 19]

However in the generated html, they are not:

  <span class="k">print</span> <span class="nb">range</span>
  <span class="p">(</span><span class="mi">20</span><span class="p">)</span> 
  <span class="go">[0,   1,  2,  3,  4,  5,  6,  7,  8,  9,</span>


Note that this issue is not present in python 2.6.8 documentation http://docs.python.org/release/2.6.8/library/doctest.html#doctest.REPORTING_FLAGS and also 3.1.5 is ok.

It appears versions at 3.2.1 and 2.7.3
msg161353 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2012-05-22 14:18
This is a duplicate of #12947.
History
Date User Action Args
2012-05-22 14:18:23ezio.melottisetstatus: open -> closed

superseder: doctest directive examples in library/doctest.html lack the flags

nosy: + ezio.melotti
messages: + msg161353
resolution: duplicate
stage: resolved
2012-05-22 14:15:30alexgarelcreate