classification
Title: Windows devguide: clarification for build errors due to missing optional dependencies
Type: enhancement Stage: resolved
Components: Devguide Versions:
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: ezio.melotti Nosy List: brian.curtin, chris.jerdonek, eric.araujo, ezio.melotti, prlw1, python-dev, tim.golden, valhallasw
Priority: normal Keywords: patch

Created on 2012-05-21 21:32 by valhallasw, last changed 2012-09-20 04:49 by chris.jerdonek. This issue is now closed.

Files
File name Uploaded Description Edit
devguide_windows_build_errors_notes.patch valhallasw, 2012-05-21 21:32
devguide_windows_build_error_notes_v2.diff valhallasw, 2012-05-22 06:44
issue-14873-1.patch chris.jerdonek, 2012-08-02 19:46
Messages (9)
msg161299 - (view) Author: Merlijn van Deen (valhallasw) * Date: 2012-05-21 21:32
The amount of errors in the solution during the windows build was surprising to me - I interpreted it as if python was not built correctly. Upon further inspection, just some extension modules were not built due to missing dependencies, and the interpreter runs without problems.

To clarify this in the devguide, I suggest the attached changes.
msg161315 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2012-05-22 01:56
3 comments on the patch:
1) I don't think this should be mentioned in the quick start;
2) You added a link to the build_dependencies target in the build_dependencies section, why?
3) Hyphens in rst should be done with '--', not '-'.
msg161317 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2012-05-22 02:20
I’m also not sure of what you meant with “the *python* package”.
msg161331 - (view) Author: Merlijn van Deen (valhallasw) * Date: 2012-05-22 06:44
Thanks for your responses!

@Ezio:
1) I can see your point. On the other hand, I also think it is helpful to have a prominent note on this - the first thing people see after following the instructions is a huge list of build errors (see the bottom of this post) - build errors that are not really 'build errors' in the normal sense, because they just mean several optional subprojects were not built.

In any case, I've removed the text from this patch. Maybe a better solution would be to add a '(details)' link to each step in the Quick Start that refers to the relevant section in the devguide?

2) Sorry; it looks that way from the patch - but it's actually in 'Windows' section - which is about a screen down from the 'Build dependencies' section on my computer. The patch in this post is a .diff instead of the hg patch format, hoping that Rietveld will pick it up then.

3) Fixed.

@Éric:
That should have been 'project', to use the VS 'solution' with 'projects' (that each build one library/executable) terminology - in this case, it refers to the project that builds python.exe (called 'python') inside the solution (called 'PCBuild').

In this patch 'project' is used consistently, although I welcome alternative wordings.


------/ error output /------
Error	3	error C1083: Cannot open include file: 'bzlib.h': No such file or directory	C:\Users\valhallasw\Documents\Visual Studio 2010\cpython\Modules\_bz2module.c	12	1	_bz2
Error	5	error C1083: Cannot open source file: '..\..\bzip2-1.0.6\blocksort.c': No such file or directory	C:\Users\valhallasw\Documents\Visual Studio 2010\cpython\PCbuild\c1	_bz2
Error	6	error C1083: Cannot open source file: '..\..\bzip2-1.0.6\bzlib.c': No such file or directory	C:\Users\valhallasw\Documents\Visual Studio 2010\cpython\PCbuild\c1	_bz2
Error	7	error C1083: Cannot open source file: '..\..\bzip2-1.0.6\compress.c': No such file or directory	C:\Users\valhallasw\Documents\Visual Studio 2010\cpython\PCbuild\c1	_bz2
Error	8	error C1083: Cannot open source file: '..\..\bzip2-1.0.6\crctable.c': No such file or directory	C:\Users\valhallasw\Documents\Visual Studio 2010\cpython\PCbuild\c1	_bz2
Error	9	error C1083: Cannot open source file: '..\..\bzip2-1.0.6\decompress.c': No such file or directory	C:\Users\valhallasw\Documents\Visual Studio 2010\cpython\PCbuild\c1	_bz2
Error	10	error C1083: Cannot open source file: '..\..\bzip2-1.0.6\huffman.c': No such file or directory	C:\Users\valhallasw\Documents\Visual Studio 2010\cpython\PCbuild\c1	_bz2
Error	11	error C1083: Cannot open source file: '..\..\bzip2-1.0.6\randtable.c': No such file or directory	C:\Users\valhallasw\Documents\Visual Studio 2010\cpython\PCbuild\c1	_bz2
Error	21	error C1083: Cannot open include file: 'openssl/evp.h': No such file or directory	C:\Users\valhallasw\Documents\Visual Studio 2010\cpython\Modules\_hashopenssl.c	40	1	_hashlib
Error	4	error C1083: Cannot open include file: 'lzma.h': No such file or directory	C:\Users\valhallasw\Documents\Visual Studio 2010\cpython\Modules\_lzmamodule.c	19	1	_lzma
Error	15	error C1083: Cannot open include file: 'sqlite3.h': No such file or directory	c:\users\valhallasw\documents\visual studio 2010\cpython\modules\_sqlite\connection.h	33	1	_sqlite3
Error	16	error C1083: Cannot open include file: 'sqlite3.h': No such file or directory	c:\users\valhallasw\documents\visual studio 2010\cpython\modules\_sqlite\connection.h	33	1	_sqlite3
Error	17	error C1083: Cannot open include file: 'sqlite3.h': No such file or directory	c:\users\valhallasw\documents\visual studio 2010\cpython\modules\_sqlite\connection.h	33	1	_sqlite3
Error	18	error C1083: Cannot open include file: 'sqlite3.h': No such file or directory	c:\users\valhallasw\documents\visual studio 2010\cpython\modules\_sqlite\connection.h	33	1	_sqlite3
Error	19	error C1083: Cannot open include file: 'sqlite3.h': No such file or directory	c:\users\valhallasw\documents\visual studio 2010\cpython\modules\_sqlite\connection.h	33	1	_sqlite3
Error	20	error C1083: Cannot open include file: 'sqlite3.h': No such file or directory	c:\users\valhallasw\documents\visual studio 2010\cpython\modules\_sqlite\connection.h	33	1	_sqlite3
Error	22	error C1083: Cannot open include file: 'sqlite3.h': No such file or directory	c:\users\valhallasw\documents\visual studio 2010\cpython\modules\_sqlite\connection.h	33	1	_sqlite3
Error	14	error C1083: Cannot open include file: 'openssl/rsa.h': No such file or directory	C:\Users\valhallasw\Documents\Visual Studio 2010\cpython\Modules\_ssl.c	91	1	_ssl
Error	12	error C1083: Cannot open include file: 'tcl.h': No such file or directory	C:\Users\valhallasw\Documents\Visual Studio 2010\cpython\Modules\_tkinter.c	66	1	_tkinter
Error	13	error C1083: Cannot open include file: 'tcl.h': No such file or directory	C:\Users\valhallasw\Documents\Visual Studio 2010\cpython\Modules\tkappinit.c	16	1	_tkinter
Error	1	error C1083: Cannot open source file: '..\..\sqlite-3.7.12\sqlite3.c': No such file or directory	C:\Users\valhallasw\Documents\Visual Studio 2010\cpython\PCbuild\c1	sqlite3
Error	2	error MSB3073: The command "cd "C:\Users\valhallasw\Documents\Visual Studio 2010\cpython\PCbuild\"
"C:\Users\valhallasw\Documents\Visual Studio 2010\cpython\PCbuild\python_d.exe" build_ssl.py Release Win32 -a
" exited with code 1.	C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.MakeFile.Targets	38	6	ssl
msg167229 - (view) Author: Chris Jerdonek (chris.jerdonek) * (Python committer) Date: 2012-08-02 15:11
I also think this would be worth a note.  May I propose a patch?
msg167248 - (view) Author: Chris Jerdonek (chris.jerdonek) * (Python committer) Date: 2012-08-02 19:46
I am attaching a proposed patch for this issue.

I also did not know whether the errors were normal when building with Windows for the first time.
msg170787 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2012-09-20 04:43
New changeset a9f8a205fa9a by Ezio Melotti in branch 'default':
#14873: add paragraph about building errors caused by missing dependencies on Windows.  Patch by Chris Jerdonek, initial patch by Merlijn van Deen.
http://hg.python.org/devguide/rev/a9f8a205fa9a
msg170788 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2012-09-20 04:47
Fixed, thanks for the patches!
msg170789 - (view) Author: Chris Jerdonek (chris.jerdonek) * (Python committer) Date: 2012-09-20 04:49
Thanks, Ezio!
History
Date User Action Args
2012-09-20 04:49:59chris.jerdoneksetmessages: + msg170789
2012-09-20 04:47:05ezio.melottisetstatus: open -> closed
messages: + msg170788

assignee: ezio.melotti
resolution: fixed
stage: patch review -> resolved
2012-09-20 04:43:15python-devsetnosy: + python-dev
messages: + msg170787
2012-08-20 14:55:38prlw1setnosy: + prlw1
2012-08-02 19:46:56chris.jerdoneksetfiles: + issue-14873-1.patch

messages: + msg167248
2012-08-02 15:11:38chris.jerdoneksetnosy: + chris.jerdonek
messages: + msg167229
2012-05-22 06:44:33valhallaswsetfiles: + devguide_windows_build_error_notes_v2.diff

messages: + msg161331
2012-05-22 02:20:40eric.araujosetnosy: + eric.araujo
messages: + msg161317
2012-05-22 01:56:53ezio.melottisetnosy: + tim.golden, brian.curtin
messages: + msg161315

type: enhancement
stage: patch review
2012-05-21 21:32:14valhallaswcreate