classification
Title: Patch to make IDLE window rise to top in OS X on launch
Type: enhancement Stage: resolved
Components: IDLE Versions: Python 3.2, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Turtle window pops under the terminal on OSX
View: 11571
Assigned To: Nosy List: Marc.Abramowitz, ned.deily
Priority: normal Keywords: patch

Created on 2012-05-19 16:45 by Marc.Abramowitz, last changed 2012-05-19 17:01 by ned.deily. This issue is now closed.

Files
File name Uploaded Description Edit
osx_raise_idle.patch Marc.Abramowitz, 2012-05-19 16:45 Patch against 2.7 to make IDLE grab focus on launch in OS X review
Messages (3)
msg161137 - (view) Author: Marc Abramowitz (Marc.Abramowitz) * Date: 2012-05-19 16:45
On OS X 10.6.8, when I execute "idle", I see nothing in the Terminal and the IDLE GUI launches but is not visible until I Command-Tab to the "Python" application. I stumbled upon a solution to this problem using OS X's built-in /usr/bin/osascript utility. Attaching a patch...
msg161138 - (view) Author: Marc Abramowitz (Marc.Abramowitz) * Date: 2012-05-19 16:53
I created the patch against the 2.7 branch of hg, but I just tried it with both the 3.2 branch of hg and an installed version of 3.2 and it worked great.

[last: 0] marca@scml-marca:~/dev/hg-repos/cpython$ pushd /Library/Frameworks/Python.framework/Versions/3.2/lib/python3.2/idlelib/ > /dev/null
[last: 0] marca@scml-marca:/Library/Frameworks/Python.framework/Versions/3.2/lib/python3.2/idlelib$ patch -p3 < osx_raise_idle.patch 
patching file PyShell.py
Hunk #1 succeeded at 1433 (offset -25 lines).
msg161139 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2012-05-19 17:01
This is really a duplicate of Issue11571 which gives an easier way to do this directly using Tk calls.  I'll see about getting that applied.
History
Date User Action Args
2012-05-19 17:01:02ned.deilysetstatus: open -> closed

superseder: Turtle window pops under the terminal on OSX

nosy: + ned.deily
messages: + msg161139
resolution: duplicate
stage: resolved
2012-05-19 16:53:03Marc.Abramowitzsetmessages: + msg161138
2012-05-19 16:45:09Marc.Abramowitzcreate