classification
Title: Python-2.6.8 install fails due to missing files
Type: Stage:
Components: Installation Versions: Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ned.deily, spacebuoy
Priority: normal Keywords:

Created on 2012-05-18 16:18 by spacebuoy, last changed 2012-05-18 17:18 by ned.deily. This issue is now closed.

Messages (2)
msg161060 - (view) Author: gene (spacebuoy) Date: 2012-05-18 16:18
Hi,
I've downloaded both source versions of Python for Mac 2.6.8 and have unziped them with Mac GUI or gunzip but all attempts fail due to build not finding files. First missing file is pyconfig.h which appears to be named pyconfig.h.in. When I remove the .in then next missing object is Modules/Setup. I don't see a fix for this. I'm installing this in Mac OS X 10.6.8. Any ideas?
Gene
Sources: http://www.python.org/download/releases/2.6.8/
msg161067 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2012-05-18 17:18
This is not the right place to get help for building or using Python (see, for example, http://www.python.org/community/lists/).  That said, you should read the README files included in the source directory, in particular, the step about running ./configure.  There are OS X specific options documented in the Mac/README file.  Also, be aware that Python 2.6 is obsolete and was released before the most recent releases of OS X and Xcode; you will likely run into problems trying to build it on them.  If you really need 2.6, you might want to consider installing it from one of the third-party open source distributions for OS X, like MacPorts, Homebrew, or Fink.
History
Date User Action Args
2012-05-18 17:18:34ned.deilysetstatus: open -> closed

nosy: + ned.deily
messages: + msg161067

type: behavior ->
resolution: not a bug
2012-05-18 16:18:07spacebuoycreate