classification
Title: Build unusable when compiled for Win 64-bit release
Type: Stage:
Components: Build, Windows Versions: Python 3.3
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: jaraco, kristjan.jonsson, pitrou, skrah
Priority: normal Keywords:

Created on 2012-05-16 00:26 by jaraco, last changed 2012-05-24 12:27 by jaraco. This issue is now closed.

Messages (6)
msg160782 - (view) Author: Jason R. Coombs (jaraco) * (Python committer) Date: 2012-05-16 00:26
It appears that sometime between 64b695a6cc3d and cdcc816dea85, the Windows x64 Release build is no longer viable. It crashes when invoking the importer.
msg160783 - (view) Author: Jason R. Coombs (jaraco) * (Python committer) Date: 2012-05-16 00:30
It seems the Win32 build is okay. Only x64 is affected.

I did a debug build, and it caught the error in errors.c line 60:

Unhandled exception at 0x1e289aeb (python33_d.dll) in python_d.exe: 0xC0000005: Access violation reading location 0x00000000000000b8.
msg161125 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2012-05-19 14:51
Could you try with latest default?
msg161175 - (view) Author: Jason R. Coombs (jaraco) * (Python committer) Date: 2012-05-20 02:04
I'd like to, but Apple hosed my Windows partition when upgrading to OS X Lion. A minor setback, but I'll be unable to test for a while.
msg161195 - (view) Author: Kristján Valur Jónsson (kristjan.jonsson) * (Python committer) Date: 2012-05-20 10:12
I am unable to reproduce.  Do you have a callastack?
msg161500 - (view) Author: Jason R. Coombs (jaraco) * (Python committer) Date: 2012-05-24 12:27
I tested against the latest tip and the issue no longer exists.
History
Date User Action Args
2012-05-24 12:27:15jaracosetstatus: open -> closed
resolution: works for me
messages: + msg161500
2012-05-20 10:12:14kristjan.jonssonsetnosy: + kristjan.jonsson
messages: + msg161195
2012-05-20 02:04:56jaracosetmessages: + msg161175
2012-05-19 14:51:10pitrousetnosy: + pitrou
messages: + msg161125
2012-05-16 11:01:55skrahsetnosy: + skrah
2012-05-16 00:30:25jaracosetmessages: + msg160783
2012-05-16 00:26:10jaracocreate